none
How to access a vendor-specific USB device with a Windows desktop app RRS feed

  • Question

  • Hello all,

    I have been working on a project, trying to built communication between my vendor-specific USB device and the PC which runs Windows 8.1. I have been getting familiar with this subject for just 3 weeks so I am sorry if i am not very clear or use wrong terms.

    For the device side, I use a PIC18F87J50 PIM and program it with MPLAB IDE C18. I wrote my program based on the demo project "USB Device - WinUSB - Generic Driver Demo". So right now, when the device is connected to a PC it s recognized and configured as a WinUSB device - loads the drivers automatically. As shown in Device Manager, .INF file is "oem27.inf" and through that file winusb.inf gets included.

    To create an application, I followed the tutorial in the website below:

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff540174(v=vs.85).aspx

    This tutorial leads you to create the application using the Visual Studio template which includes an .INF file. I need to update the driver for my device with that .INF file, but I am not able to do that because Device Manager says it already installed the best driver for the device. Now my application builts successfully but when I try to debug it all I get is 'Device not connected or driver not installed' message. What should I do to fix this? I would very much appreciate any help, thanks in advance.

    Wednesday, August 5, 2015 8:26 AM

Answers

  • Since you've changed the GUID after installing the driver, try to remove the driver and reinstall the new INF.

    Right click on your device in devece manager and select Uninstall and check "Delete the driver software".

    Then repeat installing the driver.

    -- pa

    • Marked as answer by giz.myth Wednesday, August 5, 2015 1:56 PM
    Wednesday, August 5, 2015 12:55 PM

All replies

  • I have also generated a new GUID and copied it both to my devices DeviceInterfaceGUID value (using registry Editor) and to the .INF file which is included in the application but still have the same problem...
    • Marked as answer by giz.myth Wednesday, August 5, 2015 9:31 AM
    • Unmarked as answer by giz.myth Wednesday, August 5, 2015 9:31 AM
    Wednesday, August 5, 2015 9:31 AM
  • It works, thank you very much Pavel! 
    Wednesday, August 5, 2015 1:56 PM