none
installig previous .net versions RRS feed

  • Question

  • I am running windows 7 ultimate and .net 4.5.1 is only installed .net msi on my pc in the installed programs list. my amd graphics card driver requires that .net 4.0 needs be installed and gave me the .net 4.0 Microsoft download website.

    do I need to uninstall .net 4.5.1 before I install .net 4.0?

    or

    can I install .net 4.0 on top .net 4.5.1 without causing problems?

    Saturday, October 4, 2014 10:58 PM

Answers

  • .NET 4.5 is an in-place update to 4.0, not a separate framework. If you run the .NET Framework verification tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    and look at the first ~12 lines of the tool log, you'll see that 4.0 is there.

    However, there appear to be issues (my conclusion from reading other posts) with some apps not finding 4.0 after 4.5 is installed.

    I'm not aware of any fix for this from an app user perspective, so I suggest that you uninstall 4.5 from your system, then install 4.0. Your AMD drivers should be OK, then.

    Sunday, October 5, 2014 3:35 PM

All replies