none
Select which .NET Version is required to install RRS feed

  • Question

  • I just published a simple desktop application developed in C#,VS 2010, WIndows 8.

    I created a setup file and when I try to install it on another PC(Win 7), setup installation fails due to missing of .NET Framework 4.

    Can I choose which .NET Framework version is enough to install my application manually?

    Wednesday, May 15, 2013 5:43 PM

Answers

  • You can choose which .NET Framework version to target when your solution is open in the VS 2010 IDE.

    VS 2010 allows (if installed) the choice between ,NET 4.0, 3.5, 3.0 and 2.0.

    To select the .NET Framework version, open Project->(your project name) Properties...

    In the property pages, select the Application tab (if not already selected) and find the Target Framework drop down list. Select the framework version you want to target from the list.

    Once you change the target framework, you must close VS 2010 (after saving), then reopen VS 2010 and rebuild your project.

    Note: if your solution contains multiple projects, the steps above must be repeated for EVERY project in your solution.

    Once you've changed the target framework per above, then redeploy.

    • Marked as answer by D. Chatterjee Thursday, May 16, 2013 4:39 PM
    Wednesday, May 15, 2013 6:24 PM

All replies

  • You can choose which .NET Framework version to target when your solution is open in the VS 2010 IDE.

    VS 2010 allows (if installed) the choice between ,NET 4.0, 3.5, 3.0 and 2.0.

    To select the .NET Framework version, open Project->(your project name) Properties...

    In the property pages, select the Application tab (if not already selected) and find the Target Framework drop down list. Select the framework version you want to target from the list.

    Once you change the target framework, you must close VS 2010 (after saving), then reopen VS 2010 and rebuild your project.

    Note: if your solution contains multiple projects, the steps above must be repeated for EVERY project in your solution.

    Once you've changed the target framework per above, then redeploy.

    • Marked as answer by D. Chatterjee Thursday, May 16, 2013 4:39 PM
    Wednesday, May 15, 2013 6:24 PM
  • Thank you very much pvdg42
    Thursday, May 16, 2013 4:39 PM