locked
disable login prompt win asp.net application for windows authentication using integrated windows authorization RRS feed

  • Question

  • User-922557142 posted

    Requirement :

    I am working on the scenario wherein I am changing my Application from FORMS Authentication to Windows Authentication.

    Status:

    As of now I am able to make the required changes and if I am running the application I am able to open my website directly w/o Login Prompt from IE

    i.e. Able to authenticate the user directly using windows authentication

     

    Problem:

    After deployment I used Basic Authorization in order to prompt the user once before login. And its working fine.

    But client is looking forward to even skip this step so that whenever the user tries to open the website he is able to directly access the default page(using Windows authentication)

     

    I have tried disable “Anonymous Users” and Checked the “Integrated Windows Authorization” but in this case I am getting “Internal Server Error” when trying to access my website.

     

    Please let me know in case there are any clarifications required in order to understand the above mentioned problem statement.

      

    Thanks in advance.

    Wednesday, January 21, 2015 5:16 AM

All replies

  • User-760709272 posted

    Is this an intranet site?  Is ie using intranet zone for this site?  If so does the browser have auto-login enabled?

    https://technet.microsoft.com/en-us/library/dd572939(v=office.13).aspx

    Wednesday, January 21, 2015 5:27 AM
  • User-922557142 posted

    Yes following website will be used in Intranet zone only and Auto_Login is enabled in IE Settings

    Wednesday, January 21, 2015 5:31 AM
  • User-760709272 posted

    You might have to just get to the bottom of why the site gives the internal server error then.

    Wednesday, January 21, 2015 5:33 AM
  • User-922557142 posted

    I looked into Event Viewer and also created a dummy website which does a simple windows authentication using "Integrated Windows Authentication" even then I am getting the same "Internal Server Error". When i try to browse the website in IIS itself I am able to browse my webpage.So as of now I am not able to figure out the root cause of this error.

    Yes if, I am a using Basic Authentication I am able to access the website.

    Wednesday, January 21, 2015 5:53 AM
  • User-1151753377 posted

    Hi

    Thank you for your post.

    ashutoshsharma247

    I have tried disable “Anonymous Users” and Checked the “Integrated Windows Authorization” but in this case I am getting “Internal Server Error” when trying to access my website.

    Please make some seetings as the steps below:

    On IIS disable anonymous authentication and activate Windows auth:
    - select your web application (or root if you app is place as root app)
    - select Authentication
    - disable Anonymous Authentication
    - enable Windows Authentication

    Or in the web.config file:

    <authentication mode="Windows" />
    
    <identity impersonate="false" />
    
    <authorization>
    
    <deny users="?" />
    
    </authorization>
    

     

    Best regards,

    Summer

    Wednesday, January 21, 2015 10:23 PM