none
Visual Studio 2013 freeze on startup when loading package PerfWatson

    Question

  • My Visual Studio freezes in 80% of all cases when I start it at the splash screen in the beginning. I found the /Log flag, enabled it and found out this always happens when the PerfWatson Event Provider Package is loaded:

      <entry>
        <record>56</record>
        <time>...</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [PerfWatson Event Provider Package]</description>
        <guid>{B466091B-94AD-416F-BB8A-42534D423A67}</guid>
      </entry>
    

    This is always the last entry when starting... How can I disable/repair this package? What can be the cause of this error?

    Tuesday, February 23, 2016 9:16 AM

Answers

  • After some searching I found a way to disable the PerfWatson package (not clear what it's for anyway). In earlier versions of Visual Studio it seemed to be installed as separate add-in/extension, so it could be removed from within Visual Studio. At least in VS 2013, you have to do it manually:

    • locate the GUID which identifies the package you want to disable (here B466091B-94AD-416F-BB8A-42534D423A67)
    • Use the registry editor to find the key HKEY_CURRENT_USER\Software\Microsoft\VisualStudio 
    • find and delete all occurences of the GUID below a AutoLoadPackages key

    Maybe there is dedicated way to disable build-in packages, I didn't find one.

    After this Visual Studio starts fine without loading the package that causes the freezing.


    • Marked as answer by micst Tuesday, February 23, 2016 1:55 PM
    Tuesday, February 23, 2016 1:55 PM