none
Backend relationships not showing up in front end RRS feed

  • Question

  • I added a relationship between two tables in the backend of Access. When going into the frontend, that relationship isn't there. Do I have to do an extra step? Am I supposed to manually add that relationship in the frontend after it is done in the backend?

    Thanks!

    Wednesday, September 9, 2015 6:41 PM

Answers

  • Hi Nicole. You did everything right. The relationships are established where the tables are stored, which would be the backend. Creating relationships in the frontend doesn't really affect the backend, so it's not even necessary to do that. However, if you're creating queries, you can connect or join any fields you want from one table to the next, and that also wouldn't affect the relationships created in the backend. So, in other words, you don't really create relationships through the frontend. Hope that helps...
    • Marked as answer by Nicole Bow Wednesday, September 9, 2015 9:29 PM
    Wednesday, September 9, 2015 7:16 PM

All replies

  • Hi Nicole. You did everything right. The relationships are established where the tables are stored, which would be the backend. Creating relationships in the frontend doesn't really affect the backend, so it's not even necessary to do that. However, if you're creating queries, you can connect or join any fields you want from one table to the next, and that also wouldn't affect the relationships created in the backend. So, in other words, you don't really create relationships through the frontend. Hope that helps...
    • Marked as answer by Nicole Bow Wednesday, September 9, 2015 9:29 PM
    Wednesday, September 9, 2015 7:16 PM
  • Nicole,

    If you want to see the relationships in the front end that were created in the back end, clear the relationship editor and then place your tables back in the editor.  The established relationships should be automatically displayed. 

    To clear the layout:

    1. Open the relationship editor
    2. Click the Design tab
    3. In the Tools section, click Clear Layout
    Wednesday, September 9, 2015 7:27 PM
  • Thank you so much! That clarification helps a lot, I thought there was something wrong between my backend and frontend!
    Wednesday, September 9, 2015 9:28 PM
  • What a wonderful tool, thank you!
    Wednesday, September 9, 2015 9:29 PM