locked
Data factory Web Activity to trigger logic App RRS feed

  • Question

  • Hi,

    I have Data Factory with Self hosted runtime environment with Windows 2016 virtual machine scale set which i created using ARM Template. its plain VMSS with 1 node, selfhosted runtime installed in it, no other software's installed on it.

    i have a scenario when my pipeline fails i need to send a mail by triggering logic app. when ever i execute the flow it fails with following error

    "errorCode": "2011",

    "message": "Could not load file or assembly 'CodeGenerator, Version=1.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.", "failureType": "UserError", "target": "Web1", "details": [] }

    if i use AutoresolveIntegrationRuntime and execute the flow, its executing fine. 

    is there anything i am missing in selfhosted runtime environment?

    thanks!!

    Wednesday, April 29, 2020 4:54 PM

Answers

  • Hi T_P_Karthik

    Thank you for reaching out. Since the issue is specific to SHIR, could you please tell us what is the Integration runtime version your are using? 

    I would recommend you to please try installing/upgrading to the latest SHIR version.
    Azure Data Factory Integration Runtime : https://www.microsoft.com/download/details.aspx?id=39717 
    Please let us know how it goes. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Wednesday, April 29, 2020 7:53 PM
  • I have re-installed new version of SHIR and .Net framework 8. it resolved my issue. thanks!!
    • Marked as answer by T_P_Karthik Friday, May 1, 2020 11:19 AM
    Friday, May 1, 2020 11:13 AM

All replies

  • Hi T_P_Karthik

    Thank you for reaching out. Since the issue is specific to SHIR, could you please tell us what is the Integration runtime version your are using? 

    I would recommend you to please try installing/upgrading to the latest SHIR version.
    Azure Data Factory Integration Runtime : https://www.microsoft.com/download/details.aspx?id=39717 
    Please let us know how it goes. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Wednesday, April 29, 2020 7:53 PM
  • Hi T_P_Karthik,

    Just checking to see if the above suggestion was helpful. If this answers your query, please do consider to click “Mark as Answer” and "Up-Vote" as it might be beneficial to other community members reading this thread.

    And, if you have any further query do let us know.    

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, April 30, 2020 7:51 PM
  • I have re-installed new version of SHIR and .Net framework 8. it resolved my issue. thanks!!
    • Marked as answer by T_P_Karthik Friday, May 1, 2020 11:19 AM
    Friday, May 1, 2020 11:13 AM