locked
Xamarin Download over Https did not work RRS feed

  • Question

  • User10216 posted

    I tried to reach the download over https (HTTPS-Everywhere for Firefox installed) and your server throws the following message:

    Server Error in '/' Application Object reference not set to an instance of an object

    Description: HTTP 500. Error processing request.

    Stack Trace:

    System.NullReferenceException: Object reference not set to an instance of an object at Xamarin.Activation.Trial.ProcessRequest (System.Web.HttpContext context) [0x00000] in :0

    Version information: Mono Runtime Version: 2.10.8.1 (mono210/aed10e3 Wed Dec 21 19:43:23 UTC 2011); ASP.NET Version: 4.0.30319.1

    Only for information :-)

    Hyphen

    Tuesday, April 30, 2013 7:37 AM

All replies

  • User7 posted

    Hi,

    It's likely that the HTTPS-Everywhere plugin is screwing up the process of sending information to the trial download service. I don't know how the plugin works, but I suspect the POSTed information is getting lost in the process. The information is already being sent via HTTPS, so I'm not sure why HTTPS-Everywhere is getting involved at all.

    Best, Bojan

    Tuesday, April 30, 2013 2:57 PM
  • User10216 posted

    You're right - the HTTPS-Everywhere plug-in seems not to cause the problem. Don't know what it is, on another PC its working with the same Firefox version and plug-ins. But thanks for your thoughts and investigation.

    Tuesday, April 30, 2013 5:47 PM