none
Problems with nuget package

    Question

  • Hello,

    I had so far a Windows 7 computer with Visual Studio 2012. Now i have a Windows 10 computer with visual studio 2012

    Respectively blend for Visual studio 2015.

    I Use TFS to manage my projects. Now i have the problem, that the Visual studio

    criticized that the package Microsoft.Bcl.Build {1.0.21} is missing.

    If i want to install this package i get the note that the package is already there.

    I do not know what i should do. The same project is running whitout problems on the

    old computer. I hope that somebody can help me. Best regards Martin

    Wednesday, February 08, 2017 9:59 AM

Answers

  • Hello,

    The problem was that the TeamFoundationServer probably does not safes the NuGet packages.

    Why this can’t be reinstalled later is not clear to me.

    I have now copied the entire project from the old to the new computer.

    And then there were no more problems

     Nevertheless thank you for the help.
     
    Best regards
    Martin
    Monday, February 20, 2017 12:09 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Please right click your solution and select restore nuget packages to check if the issue persists and you could click tools-> options->Nuget Packages Manger->package sources to check if the packages sources is the same with your another pc which could run the projects successfully.

    If the issue persists, please feel free to let me know.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 09, 2017 7:39 AM
  • Hello,

    The problem was that the TeamFoundationServer probably does not safes the NuGet packages.

    Why this can’t be reinstalled later is not clear to me.

    I have now copied the entire project from the old to the new computer.

    And then there were no more problems

     Nevertheless thank you for the help.
     
    Best regards
    Martin
    Monday, February 20, 2017 12:09 PM
  • Hi,

    Thank you for your update.

    Glad to know that you have solved it by yourself, could you please mark your reply as an answer which will be helpful for those who has the similar issue with you? Thank you for understanding.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 21, 2017 7:57 AM