none
WEC2013 cannot make incremental deployment RRS feed

  • Question

  • I want to debug a exe file. So, I deployed it to a folder in SD card. The folder has some jpg files. But after deployment the exe file. All other files in that fold was deleted. How to prevent those file was deleted?

    below is output from vs2013. It seems is a full deployment and uninstall all files.

    1>------ Deploy started: Project: EmeraldInstaller, Configuration: Debug EMERALD2013_SDK ------
    Connecting to Windows Embedded Compact Debugger...
    The application is already installed on the device. Checking if an incremental deployment is possible...
    Doing full deployment as project was cleaned and rebuilt...
    Uninstalling the application...
    Installing the application...
    Updating information related to installed files...
    Deploying : hard disk\emeraldinst2013\autorun.exe1>Deploying : hard disk\emeraldinst2013\autorun.exe
    1>Successfully Deployed : hard disk\emeraldinst2013\autorun.exe
    ========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
    ========== Deploy: 1 succeeded, 0 failed, 0 skipped ==========

    At the same time, I found if I start debuging, the application was running in the temporary folder(/temp/autorun), not in the deployment folder. It make me very hard to debug if the application need other resource file.
    Wednesday, November 19, 2014 2:56 AM

All replies

  • I used latest application builder. The application can be debug in deployment folder. But it sill always full deployment.
    Friday, November 21, 2014 1:36 AM