none
MMC not starting (Depends on IE8) RRS feed

  • Question

  • I get an error "MMC will not run with a version of a Internet Explorer earlier than Internet Explorer 5.5", but IE8 is not in required dependencies.
    "Internet Explorer 8 Engine and Display" package is included.


    Saturday, September 19, 2009 7:43 PM

Answers

  • You will need to add the full IE8 browser to run MMC in this build.  This is a known issue that we are working to resolve. 

    -Preston V
    • Marked as answer by Savvkin Monday, September 21, 2009 4:13 PM
    Sunday, September 20, 2009 4:47 AM

All replies

  • You will need to add the full IE8 browser to run MMC in this build.  This is a known issue that we are working to resolve. 

    -Preston V
    • Marked as answer by Savvkin Monday, September 21, 2009 4:13 PM
    Sunday, September 20, 2009 4:47 AM
  • Please note the workaround documented in Release Notes to get around this issue if you dont wish to add full IE8 browser to your image. Below is copied from Release Notes.

    To work around this issue, create a string entry (REG_SZ) with the name Version and the value "6.0.0.0" under the subkey

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer


    Hope this helps

    Thanks/Regards - Hema


    Thanks / Regards Hema R - Microsoft
    • Proposed as answer by khandaqji Sunday, May 1, 2011 6:27 AM
    Monday, September 21, 2009 8:55 PM
  • Hello Hema,

    Thanks man it works.

    Zaffer
    Tuesday, December 8, 2009 2:15 PM
  • It works Hema...Thanks...
    Thursday, December 10, 2009 2:46 AM
  • Hi Hema,

    i have the same problem with my pc. i cant access computer management or perform disk defrag, it keeps saying "mmc will not run with...etc" though i have IE8 installed. problem is, i dont know where to start and how to fix it. im not very familiar with the registry thing. can u help me? can u give a step by step procedure pls... thanks.

     

    Sunday, August 22, 2010 2:37 PM
  • Hey hema.. thanks for your solution. it worked...thanks a lot!!!
    Sunday, August 29, 2010 10:28 AM
  • thanks all my tired is done now... i am so happy now huhuhuhu
    Monday, November 15, 2010 1:54 AM
  • thanks hema i saw this with windows 7 but not in my wildest dreams thought that i will see it on windows server
    Sunday, May 1, 2011 6:28 AM
  • thanks hema its work now

     

    Saturday, October 22, 2011 8:34 PM
  • Thanks Hema... my problem is now solved.
    Monday, November 7, 2011 2:26 PM
  • Please note the workaround documented in Release Notes to get around this issue if you dont wish to add full IE8 browser to your image. Below is copied from Release Notes.

    To work around this issue, create a string entry (REG_SZ) with the name Version and the value "6.0.0.0" under the subkey

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer


    Hope this helps

    Thanks/Regards - Hema


    Thanks / Regards Hema R - Microsoft

    Thanks, its really work with winxp SP3
    Sunday, February 5, 2012 12:07 PM
  • Thank you.

    This worked perfectly and With out restart.

    imo, that proves it is just another way Microsoft is Forcing people to use ONLY thier products. If they can't win with brains and guts, they will cheat :P

    sorry you work for them Hema, but at least your helping us. Thanks again :)

    Tuesday, February 21, 2012 1:28 AM
  • Hi Hema!!

    Worked fine to me! Thanks!!

    []'s


    Tarcísio Gambin | MCP, MCTS, MCITP, ITILv3
    www.tarcisiogambin.com.br

    Tuesday, April 10, 2012 1:11 PM
  • Hello Hema, using regedit, windows7, I created a string value called New Value #1 (REG_SZ), gave it a value 6.0.0.0 (without the quotes). Since it worked for so many people I looked again. I changed the name to "Version" and it worked, duh! Thanks. BTW I have IE9. Do I need to change the 6.0.0.0 to something else?
    Friday, April 27, 2012 10:25 PM
  • Wow Hema,

    this worked like a charm on Windows XP Home SP, I already have the full IE8, but was trying to open Device Manager & was getting the 'MCC needs 5.5 error" & I had looked all over Microsoft & all the other answer were saying to do a full install :o(

    YOU ROCK GIRL!!!!

    Wednesday, May 9, 2012 9:21 AM
  • Thank you Hema! It worked for me. I could not expect such a simple solution :-) Thank you!
    Saturday, July 7, 2012 5:18 PM
  • hello Hema, this is the content of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer 

    how to create a string entry with the name Version and the value "6.0.0.0".....in which folder?

    thanks very much......

    Tuesday, July 10, 2012 7:27 AM
  • Please note the workaround documented in Release Notes to get around this issue if you dont wish to add full IE8 browser to your image. Below is copied from Release Notes.

    To work around this issue, create a string entry (REG_SZ) with the name Version and the value "6.0.0.0" under the subkey

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer


    Hope this helps

    Thanks/Regards - Hema


    Thanks / Regards Hema R - Microsoft

    Thanks Hema!

    Stive

    Wednesday, September 5, 2012 7:46 PM
  • Hi Hema,

    I have IE9 installed (version 9.0.14) and my OS is Windows 7 (32-bit) Service Pack 1. I get a similar message when I click on Computer and then right click on Manage. The pop-up heading is Microsoft Management Console and the message states that "MMC will not runwith a version of Internet Explorer earlier than Internet Explorer 5.0" I can't access device manager, computer management etc. How do I create a string entry to overcome this issue.

    I appreciate your advice on this. Thank you.

    Vijayan Menon

    Monday, March 18, 2013 1:53 PM
  • Thank you for posting the solution to the question, I was having an MMC error and this resolved it. 
    Wednesday, May 1, 2013 2:26 PM
  • Hi Hema, I don't understand the initial instructions of creating a string entry with the name Version, can you help me understand what I am supposed to do please. I have had this error for 3 years and just gave up trying to find an answer but the defragmenter won't defrag anymore and I have many \RRbackups\C in my Lenovo Care defragmenter stating that I have way more storage space on hard drive than I know I have so really do need to figure this out.  Thank you so much in advance for your assistance.

    Sincerely,  Mrs. Thomas

    Saturday, November 2, 2013 3:45 PM
  • Bloody brilliant. I've had this issue for years and never managed to solve it. This worked perfectly! Very many thanks!
    Sunday, October 19, 2014 12:06 AM
  • OK.  I tried so many things and this actually worked.  I even tried using the online call service for microsoft.  The guy tried a couple things I had already tried then told me it was fixed and moved on to his next call.  I knew it wasn't fixed.  hahaha

    So for everybody asking how to do this who doesn't have that kind of knowledge about computers:

    1. go to start .. search .. then search regedit.exe  (only one thing should come up)

    2. click on that and  look through the files.  Expanding each one until you find the right subfile HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer

    3.  Once you're in the "Internet Explorer" file  at the top you need to go to edit.. new.. string value

                                                           click sting value

    4.  Now name it Version

    5.  Now unselect it then right click right on the word Version and click Modify...

    6  Under value data type 6.0.0.0  

    and hopefully that's it for you


    Friday, September 4, 2015 9:39 PM
  • It worked for me.

    Thanks

    Thursday, September 1, 2016 11:49 PM
  • Hi Hema,

    Thanks for your solution. It worked. 

    Wednesday, March 28, 2018 1:41 AM