none
Kinect found in Device manager but not working 1.7 to 1.8 upgrade RRS feed

  • Question

  • Hi Guys,

    My kinect was working before except for the speech recognition. So I tried to upgrade to 1.8 but I got the following error:

    "The feature you are trying to use is on a network resouce that is unavailable"

    Its pointing to a folder that doesnt exist:

    C:\ProgramData\Package Cache\{075687FF-27E5-4713-9E1A-704B768811D3}v1.7.0.529\

    Its trying to find this:

    "KinectDrivers-v.7-x64.WHQL.msi"

    But this doesnt exist on my machine at all.

    I then uninstalled and re-installed the 1.7 and the kinect stopped working all together. Then after a day of trying to fix it, it started working again with the speech.

    Then for no reason later on that day it broke again and since then I havent gotten it to work.

    I have no idea why this is happening or why its acting the  way it is.

    I looked around the forums for different answers. I did find this link:

    http://community.flexerasoftware.com/showthread.php?203076-The-feature-you-are-trying-to-use-is-on-a-network-resource-that-is-unavailable

    So I tried cleaning the registry and nuking everything kinect related but still no good. I also looked around for a kinect 1.7 remove program like this one:

    http://www.how-to-uninstall-program.com/uninstaller/uninstall-Kinect-SDK-1-0-0-45-Beta-2-Kinect-SDK-1-0-0-45-Beta-2-removal-Kinect-SDK-1-0-0-45-Beta-2-windows-uninstaller.html

    But couldnt find any.The strange thing is that the kinect will show up in the device manager but just wont work with any programs on my comp or rather get detected by them. For example in the recording devices it doesnt show the kinect microphone array at all.

    Its frustrating as it was working before and now it doesnt and I cant figure it out.

    One solution I had was to nuke everything 1.7 related but the 1.8 sdk still keeps trying to find the 1.7 drivers. Is there anyway to completely remove this without having to re-install windows.

    I am on windows 8.1


    joduffy


    • Edited by joduffy Sunday, December 22, 2013 3:18 AM
    Sunday, December 22, 2013 3:17 AM

Answers

  • Have you downloaded the SDK locally to your machine or trying to install from a network share? What is the size of the files on your drive? When you un-install the previous versions did you ensure you remove the drivers, runtimes and the additional speech/toolkit files. You should not see "Microsoft Speech Platform" or any "Kinect" installers in the list of installed programs.

    From the screenshot you provided, you are missing files from the install package which shouldn't occur if you have successfully downloaded and are not corrupted. Try to re-download the binaries from the links from the blog:

    http://blogs.msdn.com/b/kinectforwindows/archive/2013/09/17/updated-sdk-with-html5-kinect-fusion-improvements-and-more.aspx

    Be sure to install the SDK before installing the toolkit.


    Carmine Sirignano - MSFT

    Friday, January 3, 2014 1:11 AM