locked
VS2010 Intellisense for C++ RRS feed

  • Question

  • I installed VS2010 Premium and created a test Win32 Console application. Once the project files are created, an error message displays to indicate that "An error occurred while creating or opening the C++ browsing database file <filename and path>.sdf. Intellisense and browsing information will not be available for C++ projects.". I originally posted this question in a couple other forums and they suggested I try this forum. I have verified that SSCE 3.5 SP2 is installed and I have tried to use a fallback location for the intellisense files with it indicating that it is a proper location, but the results are the same. I have used VS2005 & VS2008, both of which are also installed on the same machine (Windows XP SP3) and have worked but VS2010 intellisense has never worked. KB2526044 is installed as well.
    Tuesday, March 4, 2014 11:15 PM

Answers

  • Hi Bob,

    Please check this article for further information about how to troubleshoot IntelliSense in C++ Projects and the known limitations: http://msdn.microsoft.com/en-us/library/ms235519(v=vs.100).aspx

    By the way, do you mean you still get the "An error occurred while creating or opening the C++ browsing database file <filename and path>.sdf. Intellisense and browsing information will not be available for C++ projects" error message when running VS2010 on Win 7 machine?

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, March 7, 2014 3:38 AM

All replies

  • Hi Bob,

    As you already installed SQL Server Compact 3.5 SP2 and KB2526044, you should not get any Intellisense issues for C++ projects.

    After you install these updates please perform a clean startup,see: http://support.microsoft.com/kb/310353Also try running VS2010 in safe mode to avoid loading add-ins, extensions or packages. Try with the following commands:
    devenv /SafeMode
    Devenv /ResetSkipPkgs
    Devenv /ResetAddin

    In addition, on April 8, 2014, support and updates for Windows XP will no longer be available. So you'd better consider upgrading your operation system.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 5, 2014 12:42 PM
  • I've tried each of the items suggested and still have the same problem. I am in process of obtaining a new machine with Windows 7, but I had already tried the installation on a Windows 7 machine to see if I would have the problem once upgraded and it also had the same problem. I have also reset all of my environment settings under the "Import and Export Settings" option to the "General Development Settings". This did not resolve the issue either.
    Thursday, March 6, 2014 2:02 PM
  • Hi Bob,

    Please check this article for further information about how to troubleshoot IntelliSense in C++ Projects and the known limitations: http://msdn.microsoft.com/en-us/library/ms235519(v=vs.100).aspx

    By the way, do you mean you still get the "An error occurred while creating or opening the C++ browsing database file <filename and path>.sdf. Intellisense and browsing information will not be available for C++ projects" error message when running VS2010 on Win 7 machine?

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, March 7, 2014 3:38 AM