none
Hebrew Macro's in Excel worksheet does not work ... RRS feed

  • Question

  • Hi,

    I use office for mac,

    When I use Excel with Macro's using Hebrew names, the file does not work.

    Is there any way it can be fixed ?

    Kobi

    Tuesday, March 14, 2017 7:16 PM

All replies

  • Hi kobiFriedrich,

    if you provide some sample of your code then we can try to check what it looks like and why its not working.

    did you got any error message?

    if yes then let us inform about that will help us to solve the issue.

    currently , we can only suggest that try to change the name to English and check whether it work or not.

    if that work then try to install that Hebrew font on your machine may solve your issue.

    if that font already available on your machine then try to change it in VBE like below.

    these are some general suggestions that you can try to test on your side.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 15, 2017 3:05 AM
    Moderator
  • Hi Deepak,


    Hebrew is installed on my Mac.

    May I remind you I work on Mac and not on a PC.

    The error I get is:

    "Compile error

    Invalid character"

    It comes only when I have Macro's and the macro's has Hebrew in it.

    Thanks,

    Kobi

    Wednesday, March 15, 2017 9:46 AM
  • Hi kobiFriedrich,

    I know that you are using Mac.

    the issue is that Hebrew name detected as invalid character.

    so the solution is to change the names in English language so it can recognized by the VBE.

    if anything is not recognized then it will give this error.

    in some cases I had found that people try to change their default country/region , date/time to solve these kind of issues. in some cases it works too but not always. the other thing is that they all are using windows machine not mac.

    so you can try it but I am not sure about it. so if that not work then you can try to change the names in to English.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 16, 2017 6:03 AM
    Moderator
  • The file works perfect on Windows and does not work on Mac.

    It is a big file with alot of VB in it to change is to english is not possible,

    I think it is a Bug in Excel for mac that has to be fixed, don't you ?

    Thursday, March 16, 2017 8:19 PM
  • Hi kobiFriedrich,

    I don't think its a bug. if it is working in windows then there should be any setting in mac that need to be configure.

    did you set something like below? is Hebrew font is displayed here?

    unfortunately I don't have a Mac environment to make a test. can you show me a demo code of your macro.

    so I can see how it looks and if anything we can do with that or not.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 7:25 AM
    Moderator