locked
build hangs RRS feed

  • Question

  • I have a project in Blend 2 that I can't build, even if I shut down Blend and restart it.  It even hangs just on cleaning the project.  It just shows "Build started..." and hangs.  I've tried closing down Visual Studio 2008 and that doesn't seem to help.  There is no msbuild process running.

    More info on this, it turns out it's not my project.  I can't use the selection menus on the left, and even if I create a new project and try to build it Blend hangs...

    Anyone gotten this before / know a fix?  I've tried all sorts of things like clearing out app data, closing other programs, etc.  Doesn't seem to work.
    • Edited by LycheeFreeze Friday, June 27, 2008 9:07 PM not a real fix
    Friday, June 27, 2008 8:38 PM

All replies

  • You say that you can't get the project to build even if you launch Blend and try to build a new .csproj.

    a) Can you try to save the project, close Blend, and get VS to build that project?
    b) Can you build the project at the command prompt sucessfully?

    Thanks,
    Unni

    Tuesday, July 1, 2008 1:30 AM
    Moderator
  • Sorry to resurrect an old topic, but I've had the exact same problem for some time as well.  This first showed up out of the blue with a beta of Blend3, and has persisted through all builds of Blend3 I could find, including the one for .Net4

    Hangs on clean/build, no problems building with VS2010.  I've gone through everything by hand, .csproj included, and my only guess is that the likely cause has to do with fonts.  There's pretty much nothing out there on this issue, and it's rendered a very large project of mine useless to the point where I've started over again, but without blend.
    Tuesday, January 19, 2010 7:44 AM
  • Does it hang with a specific project or with all projects?  If its a specific project you can share it out and we can look at it and propose a workaround until we can get a fix in.  You can e-mail me directly at scoban at microsoft dot com

    Thanks,
    Scott
    Tuesday, January 19, 2010 10:11 PM