locked
Hosting multiple domains with multiple IPs and multiple SSL certificates RRS feed

  • Question

  • User-1931539121 posted

    I am trying add a 2nd domain to an existing webserver using the following configuration on a Windows 2000 IIS 5 server:

     

    Default website is configured as www.domain1.com

    This is secured by a self issued SSL certificate.

     

    A 2nd website was created with a different IP address and configured as www.domain2.com

    I obtained a certificate from Verisign for this address. HTTP communication works fine, but SSL does not. When I try to view the site using HTTPS, I get a certificate error in IE. I've also noticed that when I click the "View Certificate" button, the certificate says www.domain1.com, even though I'm actually going to www.domain2.com.

    Domain1.com is still working perfectly, but domain2.com is erroneously trying to use domain1.com's certificate. Does anyone know how to fix this?

     

    Thursday, April 17, 2008 5:00 PM

All replies

  • User-823196590 posted

    Do you have the IP addresses explicitly assigned to each site?

    Thursday, April 17, 2008 5:36 PM
  • User-1931539121 posted

    Both sites have explicitly assigned unique IPs. 

    Thursday, April 17, 2008 11:34 PM
  • User-823196590 posted

    Have you disabled socket pooling?
    http://support.microsoft.com/kb/238131

    Friday, April 18, 2008 8:45 AM
  • User-1931539121 posted

     I just tried the procedure from the kb article, but it's still exhibiting the same behaviour.

    Friday, April 18, 2008 11:33 AM
  • User-1931539121 posted

     Does anyone have any insight into this?

    Monday, April 21, 2008 11:44 AM
  • User738958189 posted

    I am experiencing an extremely similar issue. See my post: http://forums.iis.net/t/1149096.aspx

    Have you found a resolution yet?

    Laker
     

    Monday, April 28, 2008 2:16 PM
  • User-1931539121 posted
    No resolution as of yet, I am looking at buying a small standalone server to fix the issue. 
    Monday, April 28, 2008 4:48 PM
  • User-823196590 posted

    I've offered all the tips I can think of ... I recently had this happen to me too ... making sure that socket pooling was off and each site was explicitly assigned a unique IP, host header and port combination solved it for me.

    Monday, April 28, 2008 8:09 PM
  • User-1931539121 posted

    I haven't setup host headers at all. Do i need to? 

    Monday, April 28, 2008 10:06 PM
  • User1073881637 posted

    here is a couple suggestions.  Try making sure both the IP address for port 80 and 443 are set to the separate IP's instead of using Default All Unassigned.  Look at the command prompt and see if each IP is listening on the specific IP.s

     netstat -an -p tcp and look for port 80 and 443.

    Monday, April 28, 2008 11:40 PM