locked
SP1 made unit test projects break RRS feed

  • Question

  • When I installed visual studio 2008, unit tests worked fine.  I ran the preparation utility before applying SP1.  The following are some scenarios I've encountered after upgrading to SP1.

    Open an existing solution, which has working unit tests
    Navigate to Test View
    Test View is greyed out, and no tests exist
    Add a new Test Project, Test View is still greyed out
    Add my own test to existing test class, still grey
    Unload/Reload/Rebuild, still grey
    Close Solution

    Open some arbitrary project in its own solution(no test project)
    Generate Unit Test for a method(Automatically Generates Unit Test Project)
    Navigate to Test View
    No Tests Visible, but screen isn't greyed out
    Alter filter settings from none to project
    Test View Shows Test
    Run Test
    Test Results are empty
    Alter filter settings
    Test Results now show results
    CheckBox beside test result is greyed out

    Unload/Reload Test Project
    Tests are gone from test view
    It says "Currently no Tests are available to display"
    Changing Filter has no effect

    Manually add a new test
    Nothing changes

    Right Click project -> Add new Unit test
    Now all tests + new test are visible

    Right Click some property in code -> generate unit test
    unit test generates
    navigate to test view
    test view shows previous tests, but not new test
    click on refresh button
    "Syntax Error: Missing operand after 's' operator"
    All tests in test view go away

    Click on refresh again
    "Syntax Error: Missing operand after 's' operator"


    Is there any information I can provide?
    Sunday, February 8, 2009 11:48 PM

Answers

  • I found the cause of the problem, posted in http://social.msdn.microsoft.com/Forums/en-US/vststest/thread/53b6dd70-6a73-4204-a1be-344d0d39aca1
    • Marked as answer by Sandro997 Friday, February 27, 2009 4:12 PM
    Friday, February 27, 2009 3:48 AM