HTTP Error 502.5 ANCM Out-Of-Process Startup Failure RRS feed

  • Question

  • User1198401976 posted


    I recently had a problem on one of my servers. I would like to say that the others have the same files and that they are running without any problem. 

    In IIS, I have created a website where my APIs can be found in "C:\inetpub\wwwroot\V4_1". The APIs work well when I call them directly from the web, this one gives me an answer.

    In the same website I added an application on "C:\content\"

    The problem is that whenever I call the sub-application of the website it doesn't matter if I call a html page, an image, or an xbap application then I get error 502.5 in the title.

    Here is a typical call I make on other servers that displays the image without any problem: "server.com/content/image.jpg".

    I'm using NetCore2.2.8.

    Here is the screen of "program.cs" : 

    public class Program
            public static void Main(string[] args)
                var assembly = Assembly.GetExecutingAssembly();
            public static IWebHost BuildWebHost(string[] args) =>
                    .UseKestrel(o =>
                        o.Limits.MaxRequestBodySize = 52428800;
                        o.Limits.KeepAliveTimeout = TimeSpan.FromMinutes(30);
                        o.Limits.RequestHeadersTimeout = TimeSpan.FromMinutes(30);
                        o.Limits.MinResponseDataRate = null;
                    .ConfigureServices(services => services.AddAutofac())

    Do you have an idea how to solve this problem I tried a lot of things but I couldn't find anything that solved the problem.

    Thanks in advance

    Tuesday, December 1, 2020 10:06 AM

All replies

  • User690216013 posted

    When you try to mix an ASP.NET Core app with other types of web apps, such issues are expected.

    If you are not yet familiar with the debugging skills, try to configure different apps as individual sites and use a reverse proxy to merge URLs together.

    Wednesday, December 2, 2020 6:14 AM
  • User1065476709 posted

    Hi Saideal,

    The problem is that whenever I call the sub-application of the website it doesn't matter if I call a html page, an image, or an xbap application then I get error 502.5 in the title.

    There are many reasons that cause error 502.5, Can you post more detailed error messages?

    The most common reason for this to occur is when you haven't installed the .NET Core runtime on the server. So please first check if you have installed .NET Core runtime, if not, you can use the link below to install: .NET Core Runtime.

    Best regards,


    Wednesday, December 2, 2020 8:32 AM
  • User1198401976 posted

    Thank you for your response.

    I will see if I can set up the reverse proxy.

    Wednesday, December 2, 2020 10:28 AM
  • User1198401976 posted

    Hi samwu,

    Here is the error that appears in the event log: 

    Application '/LM/W3SVC/2/ROOT/content' with physical root 'C:\content\' failed to start process with commandline '.\Spec.Locbus.V4.Services.FrontEnd.exe ' with multiple retries. Failed to bind to port '7976'. First 30KB characters of captured stdout and stderr logs from multiple retries:

    For dotnet everything is fine as you can see: 

    C:\Users\Administrator>dotnet --list-runtimes
    Microsoft.AspNetCore.All 2.2.8 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.All]
    Microsoft.AspNetCore.App 2.2.8 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.AspNetCore.App 3.1.10 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.AspNetCore.App 5.0.0 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.NETCore.App 2.2.8 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    Microsoft.NETCore.App 3.1.10 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    Microsoft.NETCore.App 5.0.0 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]

    Wednesday, December 2, 2020 10:38 AM
  • User1065476709 posted

    Hi Saideal,

    Are there any details about the error page? Is the error message HTTP Error 502.5-Bad Gateway or HTTP Error 502.5-Process Failure?  Have you checked whether you have installed .NET Core Runtime?

    Best regards,


    Thursday, December 3, 2020 6:31 AM