locked
Error: This form is not currently browser enabled.... and it's not a browser enabled form Infopath 2003 Sharepoint 2007 RRS feed

  • Question

  • I have a form that can only be opened in InfoPath. (That's the way I want it.)

    I have a link in the emails I send from the form that directs them to the library.

    Intermittently one person will get an error message when they use the link and attempt to open the form which states:

    "This form template is not currently browser enabled. It must either be republished as a browser enabled form or opened using Microsoft Office InfoPath."

    Other people can use the link and get into the form just fine. If the affected user goes to the SharePoint site and manually accesses the SharePoint Forms Library they can open it without a problem.

    There are a few hits on this but mostly they talk about browser enabling the form which is not what I want to do. The library is set to open all forms in InfoPath.

    Any ideas?

    Friday, September 30, 2011 4:33 PM

Answers

  • I opened a case with microsoft support and this is what we found out,

    when using infopath 2010 to deploy ( with compatibility set to 2007 filler) the href value in the xml file was being set to

     

    http://<domain>/FormServerTemplates/<templatefilename>.xsn?SaveLocation=http://<path on sharepoint server>&Source=<path on server>/Forms/drafts.aspx&OpenIn=PreferClient&NoRedirect=true&XsnLocation=http://<domain>/FormServerTemplates/<templatefilename>.xsn

    which is saying open in client - however it keeps trying to open in browser.

    I re-published the template ( which is deployed as a content type in sharepoint using infopath 2007 and the href value produced is this

    href="http://<domain>/FormServerTemplates/<templatefilename>.xsn"

     

    and links to the xml file, from sharepoint tasks, in outlook and on the sharepoint site all work as expected by opening in the client.

     

    issue solved.

    so i would check what the href value is in your xml file. ( it's near the top of the file)

    MrP

     

    • Marked as answer by Emir Liu Tuesday, November 1, 2011 1:45 AM
    Friday, October 28, 2011 4:56 PM

All replies

  • I too am seeing this, and it's driving me mad ~ it seems to come and go for no reason.

    if you have infopath installed on your machine and try to access the file in sharepoint http://<server>/<site>/<library>/<filename>.xml in your browser does it open in infopath or browser?

    I believe it should open in infopath, however I am seeing one library open in infopath and one trying to open in the  browser (despite the form not being browser enabled and both libraries being set to use client application)

    can somebody from MS help out here?

     

    Friday, September 30, 2011 9:02 PM
  • Have you looked in your Central Administration Settings, under General Application Settings, InfoPath Form Services, Configure InfoPath Forms Services, and made sure that both options: Allow users to browser-enable form templates and Render form templates that are browser-enabled by users are unchecked?

     

     

    Cheers!


    Arnel
    Friday, September 30, 2011 10:53 PM
  • Yes, made no difference,

    made sure xml mime type was set to application/xml and not text/xml - no difference

     


    • Edited by mrP Friday, September 30, 2011 10:58 PM
    Friday, September 30, 2011 10:57 PM
  • this might help you - clear infopath cache on the client machine after you have several versions of the form pushed to the server:

    "C:\Program Files\Microsoft Office\Office12\InfoPath.exe" MyForm.xml /cache ClearAll

    for other infopath form commands: http://office.microsoft.com/en-us/infopath-help/command-line-switches-for-infopath-HP010148328.aspx

    Saturday, October 1, 2011 9:37 AM
  • that's not making any difference...

    any more ideas?

    Monday, October 3, 2011 5:37 PM
  • Hello Peter,

    You're emailing a link that directs your users to the library.  What is the exact url being sent in the email?  Outlook 2003? I'll investigate once I receive this information.

    Regards,

    AmandaRu-MSFT


    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, October 28, 2011 4:46 PM
  • I opened a case with microsoft support and this is what we found out,

    when using infopath 2010 to deploy ( with compatibility set to 2007 filler) the href value in the xml file was being set to

     

    http://<domain>/FormServerTemplates/<templatefilename>.xsn?SaveLocation=http://<path on sharepoint server>&Source=<path on server>/Forms/drafts.aspx&OpenIn=PreferClient&NoRedirect=true&XsnLocation=http://<domain>/FormServerTemplates/<templatefilename>.xsn

    which is saying open in client - however it keeps trying to open in browser.

    I re-published the template ( which is deployed as a content type in sharepoint using infopath 2007 and the href value produced is this

    href="http://<domain>/FormServerTemplates/<templatefilename>.xsn"

     

    and links to the xml file, from sharepoint tasks, in outlook and on the sharepoint site all work as expected by opening in the client.

     

    issue solved.

    so i would check what the href value is in your xml file. ( it's near the top of the file)

    MrP

     

    • Marked as answer by Emir Liu Tuesday, November 1, 2011 1:45 AM
    Friday, October 28, 2011 4:56 PM
  • I know this was a while ago now but it may help someone.

    We had the same problem, some users were getting the 'This form is not currently browser enabled' error whilst others were working fine.  We were using Internet explorer but when I asked the users who were getting the error to try opening the form using Firefox it would work fine.

    The solution was actually a lot simpler than editing the form. We simply cleared down the IE cached files and it started working again. The annoying thing is that it's not the first time a simple IE cache clear has solved an odd issues with SharePoint like this and I was kicking myself for not checking the basics first.

    Wednesday, September 17, 2014 9:43 AM