"Microsoft FOundation Class Library Element not found" error RRS feed

  • Question

  • I have VS2012, update 5. Looks like MFC wasn't installed during original set up, and now I am not able to add it. When I click "change" on VS in control panel, I can choose adding MFC, but after half an hour or so installation stops giving the error "Microsoft Visual C++ 2012 Microsoft FOundation Class Library Element not found". I tried running repair as well and got the same error.

    Can anyone help me to get MFC?


    Friday, April 15, 2016 2:07 PM


  • Hi,

    Thank you for posting in MSDN forum.

    >>"Microsoft Visual C++ 2012 Microsoft FOundation Class Library Element not found"

    the error ”element not found” was always due to Windows Update. In that case, please make sure you’ve patched up your OS first.

    When you go to Control Panel to do the repair, you need to make sure that the VS install packages on your machine are complete.

    Please insert a good VS 2012 ISO to repair your VS.

    If the above still doesn't help, I need you installation log file to troubleshoot this issue,

    please use  http://aka.ms/vscollectto gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to  https://onedrive.live.com/ and share the link here

    Best Regards,

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Proposed as answer by 宝宝徐 Tuesday, April 19, 2016 1:42 AM
    • Marked as answer by 宝宝徐 Monday, April 25, 2016 7:15 AM
    Monday, April 18, 2016 2:50 AM