locked
Can no longer login as Admin after publishing Club Site. RRS feed

  • Question

  • User-1521448450 posted

    I am running Visual Studio 2005 and SQL Express.   I was able to setup the Club Site on my local workstation and everything seems to work fine.   When I attempt to publish the site to a remote server (it's in the bedroom) also using SQL Express, I can no longer login with the Admin account I created.    The application event log says, "Membership credential verification failed".    I've looked through these forums, but can't seem to locate what changes I might need to make to the web.config file.    Any help would be appreciated.

    Wednesday, June 13, 2007 12:07 PM

All replies

  • User-820230059 posted

    Generally the first thing I check - when I start getting login errors - is that the correct permissions are setup on the App_Data directory.

    If you are publishing it to Windows 2000 then the user ASP.NET needs full control over the directory, if it's windows 2003 then NETWORK SERVICE needs full control over the directory.

    The issue arises because the database tracks last login (as an update query) so when it tries to write that field, and fails - it denies the user from logging in.

    Post back and let us know where you end up. :)

    Wednesday, June 13, 2007 1:28 PM
  • User-1521448450 posted

    Well, I gave ASP.NET account FULL CONTROL over the APP_DATA directory, but unfortunately I am still unable to logon with the Admin account which was created on the DEV workstation.   The error message from the login control is Your login attempt was not successful. Please try again.    When I check the Application Event log on the W2K server, the error message is as follows:

    Event Type: Information
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1315
    Date:  6/13/2007
    Time:  2:42:32 PM
    User:  N/A
    Computer: SERVER05
    Description:
    Event code: 4006
    Event message: Membership credential verification failed.
    Event time: 6/13/2007 2:42:32 PM
    Event time (UTC): 6/13/2007 7:42:32 PM
    Event ID: af524bd6ce134d8b9b17297fb89d3c8b
    Event sequence: 9
    Event occurrence: 3
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/Root/ClubSite-1-128262370423771552
        Trust level: Full
        Application Virtual Path: /ClubSite
        Application Path: C:\Inetpub\wwwroot\clubsite\
        Machine name: SERVER05
     
    Process information:
        Process ID: 2412
        Process name: aspnet_wp.exe
        Account name: SERVER05\ASPNET
     
    Request information:
        Request URL: http://server05/ClubSite/Default.aspx
        Request path: /ClubSite/Default.aspx
        User host address: 192.168.0.100
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: SERVER05\ASPNET
     
    Name to authenticate: John
     
    Custom event details:
     

    Wednesday, June 13, 2007 2:52 PM
  • User-820230059 posted

    Thats an interesting situation you have there. [:D]

    Let me dig around a bit and see if I can come up with anything.  Do other users accounts work by chance, have you tried registering as a new user on your site, and then logging in as that user?

     

    Wednesday, June 13, 2007 4:34 PM
  • User-1521448450 posted

    It's working now!    In addition to granting the ASPNET account READ/WRITE privileges to the APP_DATA folder, I had to grant the permissions to the individuals files within the folder.    That did the trick.   Thanks for the help. [:D]

    Wednesday, June 13, 2007 5:31 PM
  • User-820230059 posted

    Glad I could help.  I should have mentioned that I suppose.  I get lazy with 2003 and XP / Vista permissions, that will propogate to files inside folders by default (it's a checkbox)

     

    Thursday, June 14, 2007 9:13 AM
  • User1044574888 posted

    You are smart guy! Your advice really help me to solve my frustration in last 2 days.

     Thanks

    Monday, September 17, 2007 8:36 PM
  • User1895452340 posted

    I am having this same problem.  I gave the aspnet machine account rights to the apps_data folder and all sub files, but still can't login.

    Thursday, October 4, 2007 6:40 PM
  • User1594909186 posted

    Hi guys. Did you find a solution to this problem, because I am having the same problem. Please help

    Wednesday, June 24, 2009 9:31 AM
  • User1594909186 posted

    I found the solution. I shared the folder for my project and also allowed users access to the folder throught security Tab. Thank you very much

    Thursday, June 25, 2009 2:09 AM