locked
What am i missing that my user account cant upload a document to a virtual directory. RRS feed

  • Question

  • User1324895001 posted

    So we have been working on a intranet site for our office and because we have 2 network shares where all our documents and projects exist, im trying to allow users to upload only pdf files to the server within one of our pages..

     

    I had our network guy create an account on the shares that has full read/write access to the share and ALL subfolders, from the web server i can map a drive to the share with the login and password, in IIS for the virtual directory i created, i changed over to "connect as" and supplied the same credentials, but when i try to upload using the form, i get "Access to the path is denied."

    Since we are a small company and dont have domain servers setup here, what else can i check or do to see about fixing this error?

     

    thank you

    Monday, May 5, 2014 1:34 PM

All replies

  • User1324895001 posted

    One thing i forgot to mention is that the site we have setup is using

        <authentication mode="Forms">
          <forms loginUrl="Login.aspx" timeout="2880"/>
        </authentication>

    so is it possible to leave this authentication in place and still have the uploading process use the account the network team setup?

    Monday, May 5, 2014 3:10 PM
  • User1324895001 posted

    Anyone?

    We have reset permissions, and we can map and access the folder and share on the web server using the account created for the site.. so the server is able to access it, but when i try to upload i get the access denied.

     

    Let me make sure this is correct. I setup the virtual directory with the following:

    in IIS7 it shows the following

    Application Path = Root Application
    Virtual Path = /Projects
    Physical Path = \\ourserver.com\projects
    Identity = remoteservername\username

    So since the VD is already mapped to the "projects" folder, do i have to provide that as part of the path used to upload the file?

    Monday, May 5, 2014 5:32 PM
  • User-183147428 posted

    Hello. Sorry if this is too obvious, but are you sure that you've set up impersonation correctly in web.config?

    <identity impersonate="true" userName="domain\user" password="whatever"/>

    That would be the "ASP.NET Impersonation" setting within the authentication settings if you're going about it in IIS.

    Monday, May 5, 2014 6:11 PM
  • User1324895001 posted

    I have the following:

        <identity impersonate="true" userName="DDD\XXXX" password="XXXXXXX"/>  
        <authentication mode="Forms">
          <forms loginUrl="Login.aspx" timeout="2880"/>
        </authentication>

    Tuesday, May 6, 2014 12:34 PM
  • User-183147428 posted

    You've successfully connected to the share using the account's credentials, but have you also successfully written to the share?

    Friday, May 9, 2014 1:31 PM