Required CD/DVD drive device driver is missing


  • I'm trying to install the developer preview and right after the install starts I get an error - Load Driver


    A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive please insert it now.


    Where do I find a driver? How is the setup able to use my CD/DVD drive?



    Wednesday, September 14, 2011 2:37 PM

All replies

  • post use more details about your Hardware? Do you run SATA devises in AHCI or IDE mode?

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, September 14, 2011 2:44 PM
  • I get the same error when trying to install x64 version on Oracle VM. The CD is an IDE disk the disk is a SATA running in AHCI mode.

    Using diskpart I can select the virtual hard disk and partition and format it.

    I can see the X: drive (MINWIN)

    I can NOT see the CD/DVD drive.

    Under Oracle VM there are a number of options to change the CD IDE controller type that the CD-ROM is attached to, ICH6, PIX4, PIX3. I have tried all three - no luck.

    I have toggled the CD/DVD pass through option - same result.

    I have also, against the IDE controller, toggled the 'Use hsot I/O cache' option - same result.

    I do not appear to be able to create another type of CD-ROM drive.

    The W8 ISO is a mounted as a virtual file - it has NOT been burnt to DVD. It is NOT in the physical drive.




    Wednesday, September 14, 2011 3:03 PM
  • I had the same error on my first attempt.  As it turns out, I checked the iso and it failed a hash check.

    You might want to do the same.

    Wednesday, September 14, 2011 3:05 PM
  • On Wed, 14 Sep 2011 15:03:55 +0000, FearofWeapons wrote:

    The W8 ISO is a mounted as a virtual file - it has NOT been burnt to DVD. It is NOT in the physical drive.

    A virtual file in the host OS, or connected directly to VirtualBox? If the
    former, then do the latter instead.

    Paul Adare
    MVP - Identity Lifecycle Manager
    Multitasking = screwing up several things at once.

    Wednesday, September 14, 2011 3:11 PM
  • Try installing using USB harddrive
    Wednesday, September 14, 2011 3:13 PM
  • It' a PLDS DVD+-RW DU-8A3S ATA Device. The Win7 driver is cdrom.sys.
    Wednesday, September 14, 2011 5:32 PM
  • i am trying to do a regular install from dvd ... getting the cd/dvd driver error and feeding it the driver doesn't work
    Wednesday, September 14, 2011 6:02 PM
  • same for me. i've tried creating the DVD twice, including downloading the ISO file.

    win8 #fail

    Wednesday, September 14, 2011 8:23 PM
  • The same thing.

    I want to install W8 from ISO or USb Flash Drive but without formatting.


    I created boot record with Easy BCD to boot from ISO

    I copied ISO contents and created boot record to boot.wim on USB Flash Drive


    The same thing is happen for this two cases.

    I even don't have dvd drive in my HP tm2t laptop. WTF?


    Also I started installation from Windows 7 x64 - Setup tells me that my laptop is not ACPI Compliant...

    Friday, September 16, 2011 1:46 PM
  • I got the same error while installing 32-bit Win8 from a USB drive. At the time of the error the USB drive cannot be accessed. It seems the drive is not visible for some reason. I figured it might be that the installation does not recognize NTFS, so I re-formatted my USB drive as Fat32 and re-copied the files in the ISO to it.

    After that, it worked without any problem. If you are using a physical CD/DVD drive, you may get the problem if the installation does not recognize the drive for some reason. The problem is a little strange, because apparently the drive was recognized at the beginning otherwise the installation would not even start.

    Monday, September 19, 2011 6:11 PM
  • It doesn't work for me at all.  I get "A required cd/dvd drive device driver is missing" On 3 different machines and even through virtual box.  And....I used both the x86 and x64....same issues everywhere.  I have downloaded the software from multiple sites.  Please enlighten me and tell me what I'm doing wrong here.  2 of thes machines are much newer and should not have any issues.  And once is only about a year old and still should not have any issues.
    Any find a resolution for this?
    Friday, September 23, 2011 10:30 PM
  • You may have a corrupted download. I have seen this error when the ISO is corrupted. This error may be caused by a bad burn of the .iso. Try re-downloading and re-burning the .iso file. On Windows 7, the easiest way to convert this file is to use Windows Disc Image Burner


    Can you verify if the virtual DVD ROM has a drive letter assigned to it ?
    To verify if the virtual DVD ROM has a drive letter:

    1. Boot off the ISO and press and hold the Left Ctrl key as you see the boot progress bar.
    2. You will see a Command window launching, in that run Diskpart
    3. Then run "List Volume"
    4. See if the virtual DVD ROM has a drive letter.


    • Proposed as answer by MleeTaos Tuesday, January 10, 2012 1:27 AM
    Sunday, October 2, 2011 6:28 PM
  • In my case it was a bad download.  We found another site and re-downloaded it from there and it burned and worked fine.  I hope eveyone else had come across that fix as easy as I did.  I will mark marilyn's answer as the Answer although we found this solution WAY back when I first posted this question and no one had answered.  I am just now getting back to cleaning up my posts.  But thanks for all the replys and again hope all is well.



    Tuesday, January 10, 2012 1:27 AM