locked
Getting NetworkConnectionFailure error after updating Universal Ad SDK RRS feed

  • Question

  • I have a basic interstitial ad that was working fine until last night when I updated the Universal Advertising SDK. After the update I'm getting a "NetworkConnectionFailure" error every time; even the test ads stopped working. I was also able to reproduce this on multiple devices and in the live version of the app.

    I have a very basic setup; identical to the sample code. And again it worked fine before, up until last night after updating the SDK.

    Tuesday, January 26, 2016 4:20 PM

All replies

  • Is this app targeting 8.1 or 10/UWP?  XAML or HTML?
    Tuesday, January 26, 2016 7:33 PM
  • Nate,

    ignore my question. pretty sure I found one of your games (Win10/XAML) and got a repro. I'm going to need to reach out to Freewheel since the server there is returning an HTTP 403 leading to the SDK error. same SDK build here I see ads so not sure yet what's going on, but could be related to refactor to drop our msxml dependency.

    Tuesday, January 26, 2016 7:46 PM
  • Hi Matt,

    This would be for Darksong Chronicles, specifically the Win10 PC version (C++ DirectX).

    Thanks for looking into this!

    Tuesday, January 26, 2016 8:46 PM
  • thanks Nate. That's the title I traced. we have root cause, looks as if the user-agent is not getting populated correctly in the http call, and Freewheel is rejecting the request. no ETA as yet on fix.
    Tuesday, January 26, 2016 9:12 PM
  • Just to say we look as though were suffering the same issue...

    Win10 C++/XAML/DirectX apps

    Thursday, January 28, 2016 12:48 PM
  • Any update on this fix?
    Thursday, January 28, 2016 9:22 PM
  • We have a fix ready internally that we are testing. We expect to release next week - you will not need to do anything for users to get the fix, since it ships in the framework package.  I'll post instructions for syncing your dev machines once the bits are available, as we will not likely ramp the Gallery page MSI
    Friday, January 29, 2016 5:55 PM
  • I am having the same problem, windows 10, XAML. Only difference in my case is that it is only the videos that are not working. Even tried on a newly formatted computer, with a clean install of Visual Studio and an exact duplicate of the sample code here. https://msdn.microsoft.com/library/mt313191(v=msads.30).aspx     Keeps generating Network Connection Failure
    Saturday, January 30, 2016 8:48 PM
  • Same problem here, any update?
    Tuesday, February 2, 2016 10:52 PM
  • So well over one week on and no sign of any fix... whats going on?
    Thursday, February 4, 2016 9:35 AM
  • Also waiting for an update on this.
    Thursday, February 4, 2016 3:12 PM
  • Hi Nate, an update...

    The framework code went out last night so clients using Win10 apps out in the wild will start self correcting.  We will publish a 2.0.5 installer early next week after we get signed bits so same fix is available in your local dev env.

    Friday, February 5, 2016 6:21 PM
  • So to clarify, those users with Win10 PC/Phone will begin to have ads being available today automatically, without any sort of update? (specifically, full screen video ads start to return available ads)
    Friday, February 5, 2016 6:29 PM
  • I'm still getting a NetworkConnectionFailure on Windows 10 even when requesting the test video ad, although the test ad for Windows Phone 8 appears to be loading correctly.
    Sunday, February 7, 2016 6:37 PM
  •      The problem has not corrected on any win 10 clients for me either
    Monday, February 8, 2016 3:47 AM
  • Got the same issue, sitting on a Windows 10 PC.

    Can we get a fix on this ASAP?! I'm so tired of opening up projects to update some SDKs and shit stops working...and this is not the first time (and for some stupid reason I always wonder if I made an error somewhere, before I manage to find the issue on this god awful forum). How can these issues even slide through testing?

    Thanks...

    Tuesday, February 9, 2016 10:45 AM
  • the hotfix to framework is now in the MSI so you'll have parity between what you test locally and what users see.
    Tuesday, February 9, 2016 10:47 PM
  • I have a notification setup that tells me in real time how many players have an ad ready and how many have watched an ad. Since yesterday I'm seeing a very small percentage of users finally having an ad ready and successfully completing them (although the vast majority still do not). Hopefully that number increases as the fix propagates, but I can confirm it is slowly starting to work again.
    Tuesday, February 9, 2016 10:52 PM
  • Feb 12_2016 and I am getting a network error while testing the workings of an interstitial ad.  Does anyone know if this has been fixed and what is needed to get the fix??
    Saturday, February 13, 2016 5:12 AM