none
Can 3.5 coexist on PC with 2.0 and 3.0? RRS feed

  • Question

  • Hi,

     

    On my new Vista I have Framework 2.0 and 3.0 living happily. I want to try 3.5 but I have to be sure that doesnt break any of my 2.0 / 3.0 projects. Can I install framework 3.5 and have it coexists with framework 2.0 and 3.0?

     

    --

     

    Monday, December 10, 2007 8:56 AM

Answers

  •  

    The .Net Framework 3.5 can happily live side-by-side with 2.0 and 3.0 on your Vista machine, and you shouldn't notice any difference in your existing .Net 2.0 or 3.0 applications.  That being said, .Net 2.0 SP1 and .Net 3.0 SP1 are installed when you install .Net 3.5 -- those service packs fix bugs with the existing versions of the Framework.  It's possible, though very, very unlikely, that those changes could unwanted behavior in one of your existing projects.

     

    So I'd recommend going ahead and installing 3.5.

     

    Hope this helps,

    Nick Doty - MSFT

    Tuesday, December 11, 2007 4:02 AM

All replies

  •  

    The .Net Framework 3.5 can happily live side-by-side with 2.0 and 3.0 on your Vista machine, and you shouldn't notice any difference in your existing .Net 2.0 or 3.0 applications.  That being said, .Net 2.0 SP1 and .Net 3.0 SP1 are installed when you install .Net 3.5 -- those service packs fix bugs with the existing versions of the Framework.  It's possible, though very, very unlikely, that those changes could unwanted behavior in one of your existing projects.

     

    So I'd recommend going ahead and installing 3.5.

     

    Hope this helps,

    Nick Doty - MSFT

    Tuesday, December 11, 2007 4:02 AM
  • When my workstation having .net framework 1.1 and 2.0 SP1,
    In the Computer Management ->IIS->Default Web Site-> Right Click on any Virtual Directory and select Properties
    I was able to see an ASP.net tab and being able to choose different .net framework for the select Virtual Directory.  That is, I can make different Virtual Directory (different application) to use different version of .net Framework.

    However, after installing web developer 2008 (.net framework 3.5 will be automatically installed together), the ASP.net tab on the Virtual Directory's Properties is gone.

    Can anybody tells me what is going on?  Do I suppose to be still able to choose different .net framework for different Virtual Directories?

    Thank you.
    Tuesday, April 21, 2009 11:31 PM