Build Agent Error: No Endpoint Listening & AddressFilter mismatch at the EndpointDispatcher


  • Hi,

    I am having real issues getting the TFS Build Service running in conjunction with Lab Agent on the same machine. The first issue I had was the error saying "there was no endpoint listening at....", and since Lab Agent would not allow me to change the Local Build Service Endpoint (incoming) to use IP Address instead of host name, I added an entry to the hosts file on my TFS Server so that it could see the machine using the hostname.

    After doing the above I now get an error saying: "The message with To 'http://hostname:9191/Build/v3.0/Services/Agent/11' cannot be processed at the receiver, due to an AddressFilter mismatch at the EndpointDispatcher. Check that the sender and receiver's EndpointAddresses agree.".

    Can somebody please assist with a solution to this - I have been struggling for more than a week to get a simple Build Service running with just an Agent connecting to my Build Controller (which is on different Vm and working great).

    The moment I uninstall Lab Agent then TFS Admin Console allows me to change the address to IP and then it all works, but when putting Lab Agent back on, this problem is back.


    Danie Spreeth

    Wednesday, June 08, 2011 9:25 AM

All replies

  • *bump*

    The silence is deafening! Anyone?

    Friday, June 10, 2011 6:41 AM
  • Hi Danie,

    I'm having the same issue and found this:



    Will it help you?  I haven't been able to test this out yet.



    Monday, June 13, 2011 7:21 PM
  • Hi Felix,

    Thanks, but that was one of the first posts I found and tried after googling the error... I am still stuck.


    Tuesday, June 14, 2011 6:29 AM
  • "bump" again....

    Seriously - its been 3 weeks since I posted this...

    Monday, June 27, 2011 7:43 AM
  • 4 weeks and counting...
    Monday, July 04, 2011 1:23 PM
  • Try restarting the windows service, "Visual Studio Team Foundation Build Service Host " in build controller and "Test Connection " in properties.

    Tuesday, July 05, 2011 7:13 AM
  • Hi Varshant,

    Thanks for the post - at least there is some movement here now.

    Restarting the service does not help. Keep in mind that while trying to get this working, I rebooted several times, I even deleted the VM completely and recreated it from scratch a few times as well (reinstalling everything) and the same error keeps appearing.


    Tuesday, July 05, 2011 9:13 AM
  • I'm sure.

    Restarting the service fixed the problem for me.

    Two things I've done initially.

    1. Restarted the above said Windows Service.

    2. Restarted the controller, so that all build agents are refreshed.

    After that I don't see that issue, and test connection is successful, once all agents are back to ready state.

    Wednesday, July 06, 2011 9:29 AM
  • Danie,

    You might want to check if you are using a fully qualifed hostname and how its specifically set in your host file.  I've had issues using anything other than just the host name that I detailed here http://www.thecto.org/post/Team-Foundation-Build-Service-2010-Controller-Agents-and-FQDNs.aspx .

    Not sure if this will help but thought I'd mention it in case.



    • Proposed as answer by Gary Gauvin Wednesday, September 07, 2011 1:14 AM
    Monday, July 11, 2011 5:22 AM
  • i'm also encountering the same problem. looking all over the internet for a solution resulted with nothing.

    pleease -helppppppppppppp,


    Monday, October 17, 2011 9:27 AM
  • i'm also encountering the same problem. looking all over the internet for a solution resulted with nothing.

    pleease -helppppppppppppp,


    Monday, October 17, 2011 9:30 AM
  • thankyou,

    i configured a new controller and erased the old one and it worked

    Thursday, October 20, 2011 6:46 PM
  • thankyou,

    i configured a new controller and erased the old one and it worked

    Lucky I am still stucked :(

    Regards Nain
    Monday, December 19, 2011 7:33 AM
  • I have performed following steps to get it resolved.

    1 - Uninstall Build Services

    2 - Re-Install Build Services

    Regards Nain
    • Proposed as answer by rznain Monday, December 19, 2011 9:15 AM
    • Edited by rznain Monday, December 19, 2011 10:08 AM
    • Unproposed as answer by rznain Tuesday, December 20, 2011 5:59 AM
    • Proposed as answer by BarrinTe Thursday, January 12, 2012 11:28 PM
    • Unproposed as answer by BarrinTe Thursday, January 12, 2012 11:28 PM
    Monday, December 19, 2011 9:14 AM
  • Greetings.

    I have had the same problem a few times. Besides the above mentioned suggestions, verify that any proxy settings are correct.

    You can get to the settings by opening Internet Explorer and selecting "internet options"

    • Open Internet Explorer
    • Selecting "Internet options"
    • Click "Connections" tab
    • Click "LAN settings" button

    If your network is not configured to push settings automatically, make sure you uncheck the "Automatically detect."

    If you specify a proxy, make sure you also check "Bypass for local traffic."

    This has worked in one situation

    Thursday, January 12, 2012 11:42 PM
  • I ran into the same error on my build controller.

    I think this was caused by rebuilding the server but not the build machine.  So the build machine had the services installed when the TFS server came online.  I had also deleted the controller and agent at some point.

    When I restarted the build service from the Team Foundation Server Administration Console on the build machine I got error events recorded.  Looking at the details showed that the build ID no longer had the correct permissions in TFS.  (Because I had restored from backups when I rebuilt the server.)

    Adding the build ID to the "Project Collection Build Service Accounts" group and restarting the service 1 more time fixed the problem.

    Friday, March 23, 2012 7:09 PM
  • Hi all,

    Had the same issue and found another way out. Posting to let you know.

    The root cause was connection of the computer to the domain. I was logged in to the domain but when adding a user to a TFS group I only got the local computer on the "Locations" list.

    Our problem was that we use a virtual machine and we moved it to another machine which caused the machine to lose it's IP (we have fixed IP addresses scheme). We were able to log in but still...

    After fixing it we go the domain in the locations and the agent up and running.



    Wednesday, April 18, 2012 1:18 PM