locked
Can't access data once app is deployed RRS feed

  • Question

  • Hi guys!

    I have a SL4 app wich is deployed in my dev machine (just to test it). Windows 7 and ISS 7 is the current scenario. The app has an App_Data Folder where the mdf database is located. When running the app from visual studio, everything works fine, I can interact with the database... but when I run it in the localhost, I get an error everytime I reach a moment when a conection to the DB must be stablished. Here is the error:

    "System.ServiceModel.DomainServices.Client.DomainOperationException: Load operation failed fore query 'GetProducts'.... Failed to generate a user instance of SQL Server due to failure in retrieving the user's local application data path. Please make sure the user has a local user profile on the computer. The connection will be closed"

     The App_Data is where it is suposed to be... and the issue with the user, not sure  what is it talking about. Can anyone help me?

    Thanks in advance!

    Thursday, May 27, 2010 9:15 AM

All replies

  • Hi nangua!

    i'm so glad that you answered me. It's working... I've been stuck with this for a week. I read both links and coudn't solve it until now. I'm describing the steps I took in case that anyone else has the same problem (follow the first link nangua gave me)

    I follow the steps in the first link that are described in the Solution for Windows 7 and Windows Server 2008 R2.

    After that, it was still not working... and I was getting mad! Just make sure that the Pool you modified (Asp.net V4.0 in this case) is the one you are using in your web app (I had the DefaultAppPool and that's why I was not noticing any changes haha)

     Thank you very much!

    Monday, May 31, 2010 3:20 PM