none
"System.ArgumentException: Font '?' cannot be found" during application start up. Any ideas? RRS feed

  • Question

  • We have couple of users that get this error when they run our application.  I have never seen this problem before. Client says fonts are installed and Microsoft Sans Serif font is there as well. Also he states that user has Read permissions to %SytemRoot%Fonts folder.

    Any suggestions or ideas how to fix this problem will be appreciated. Thank you. 

    Here is the stack:

    Exception: System.ArgumentException: Font '?' cannot be found.

      at System.Drawing.FontFamily.GetGdipGenericSansSerif()

       at System.Drawing.FontFamily.get_GenericSansSerif()

       at System.Drawing.SystemFonts.get_DefaultFont()

       at System.Windows.Forms.Control.get_DefaultFont()

       at System.Windows.Forms.Control.get_Font()

       at System.Windows.Forms.Control.AssignParent(Control value)

       at System.Windows.Forms.Control.ControlCollection.Add(Control value)

       at Bloomberg.SmartClient.Hosting.ErrorControl.InitializeComponent() in C:\Projects\Source\Client\ApplicationHosting\ErrorControl.cs:line 218

       at Bloomberg.SmartClient.Hosting.ErrorControl..ctor(String appTitle, Boolean inPanel, Exception exception) in C:\Projects\Source\Client\ApplicationHosting\ErrorControl.cs:line 119

       at Bloomberg.SmartClient.Hosting.ApplicationHost.OnDisplayError(ApplicationDescription appDescription, Exception error) in C:\Projects\Source\Client\ApplicationHosting\ApplicationHost.cs:line 849


    Thursday, September 2, 2010 2:17 PM

Answers

All replies