locked
CE 5.0 Network and Dial-Up Connections icon accidentally deleted RRS feed

  • Question

  • We have customers that keep accidentally deleting our Wi-Fi card icon from the Network and Dial-Up Connections. I have searched and searched and cannot find where connmc.exe decides what icons to display.  The Wi-Fi driver is loaded and running.  How can I restore the icon (registry?  config file?).  Surely there is a way without reflashing the OS.

    CE 5.0 on ARM

    Wednesday, March 1, 2017 9:56 PM

All replies

  • Hi David,

    Do you know what the values are in that setting? Can it be re-entered using the add connection option?

    Sincerely,

    IoTGirl

    Wednesday, March 1, 2017 11:10 PM
  • It cannot be added under New Connection since the Wi-Fi card does not show up in the list (only COM ports and USB cable).
    Thursday, March 2, 2017 12:35 AM
  • That sounds quite odd. Do you have an install package you provide in order to deploy the driver? Is that addition part of your installer?  Can they re-run that installer?
    Thursday, March 2, 2017 1:12 AM
  • I have re-run the installer and it doesn't replace the missing icon.
    Thursday, March 2, 2017 1:14 AM
  • I am afraid I don't have a good answer for you but the documentation does show how this all fits together for CE 5 here: https://msdn.microsoft.com/en-us/library/aa448384.aspx

    There is a link to the auto config architecture there.


    Thursday, March 2, 2017 1:25 AM
  • I never found anything helpful in those links so I had to re-flash the board back to factory stock, then install the driver again.
    Monday, March 6, 2017 7:41 PM
  • Hi David,

    Were you able to track the installer?  Is there a method by which you could have deleted more than just the link and the reinstall would work?

    Sincerely,

    IoTGirl

    Monday, March 6, 2017 8:29 PM
  • I had previously tried uninstalling the driver and deleting all the registry entries I could find for it, then reinstalling the driver.  Still no luck.
    Monday, March 6, 2017 11:18 PM
  • You would have to delete and then reset to force a reload of the registry.
    Tuesday, March 7, 2017 1:15 AM