none
Asrock Z87 Fatal1ty Windows 10 - Intel Series 8 USB3 controller incompatible - Listed some troubleshooting performed - please help RRS feed

  • Question

  • Well I got my Kinect v2 for Windows Camera today expressed out from MS although I selected free regular postage... was delighted by this extra service, as it is father's day this Sunday and I was intending to use it. But what a nightmare it has been setting it up. And so bloody expensive for what it is... but that's a totally different issue. 

    My motherboard model is stated in the title, I have 16gb ram, Intel I7-k4770 @3.5ghz, GeForce 970gtx, 4tb hdd. and I get all green ticks from the Kinect Config. verifier except for the USB 3 not being able to determine the bandwidth. why should this be an issue if I'm getting a feed at 30fps from both infrared and video cameras? Windows Devices detects a Kinect and NuiSensor Adaptor as 'Unspecified'...

    I wanna stream video on skype and xsplit (but they currently don't detect a camera) and maybe one day when the developers and MS get their act together I'd love to scan 3D models into 3ds max or something open-source to create photorealistic still and animated renders :)

    Let me list the things I have done so far.

    • Downloaded the Kinect Configuration verifier
    • read lots of forums
    • upgraded from Windows 7 to windows 10
    • manually re-downloaded and installed all the intel drivers for my motherboard for windows 10 from Asrock website
    • The newest Intel USB 3 Host Controller (4.0.0.36) downloaded from the Intel website doesn't install on my computer saying "My computer doesn't meet the minimum requirements". My current Windows 10 compatible driver was automatically installed during the Windows 10 upgrade, and dated as 09/july/15
    • Updated BIOS from v.1 to v1.7
    • Tried various settings in the BIOS for USB configuration settings in regards to, disabling and enabling the legacy support and other USB 3 options.
    • disconnected all usb3 devices, leaving only usb2 keyboard and mice connected.
    • I also have a Wacom Cintiq that might be stealing resources from usb3 as it also connects to the onboard hdmi, but I have disconnected both and tested and still no approval from Kinect verifier

    One thread suggested hooking up the PCIx to the chipset on the motherboard... I'm not sure if this is relevant to me but I have omitted this because I couldn't find the connection of the motherboard manual, maybe I missed it, but does anyone know if my mobo chipset needs to connected the PCIx to make the bandwidth 5gb/s? It seems like my USB3 devices are working fine, getting high-bandwidth file transfer on USB3 flash drives.

    One other solution was to buy a USB 3 card with gen 2 intel chipset compatibility for PCIx... this seems like a last resort to me.

    Does any one know what I'm doing wrong or suggest a fix? Any help is greatly appreciated. Thanks in Advance.

    Friday, September 4, 2015 7:58 PM

All replies

  • One thing you haven't mentioned, the Kinect SDK v2. Have you installed it? It might have an effect.
    Saturday, September 5, 2015 12:27 PM