none
Exported Item Template not appearing in Available Templates

    Question

  • Using VS 2015 community edition on Windows 10 anniversary edition within a C# project:

    I export a Forms class by going to the VS File menu and selecting "Export Template...", I go through the options to export the Template as an 'Item" and I see the zip file placed in my:

    "Documents\Visual Studio 2015\My Exported Templates", the exported file is also placed in my:

    "C:\Users\RicoMiledi\Documents\Visual Studio 2015\Templates\ItemTemplates" which is the location specified by the VS | Options | Projects and solutions user item templates location.

    Before exporting the Form I verify that the project compiles. The exported zip file looks OK but if I try to create a new class I do not see the newly exported class but I do see other classes that I have exported previously but that do not appear in either of the two locations mentioned above.

    It would seem that there is a discrepancy between where the templates are exported to and from where they are imported from, how do I reconcile this?

    Thank you.

    Wednesday, November 16, 2016 10:01 PM

Answers

  • My mistake.

    I have ReSharper installed and it has it's own Template mechanism - which was showing templates that I had added to it, the new item template was correctly added but is shown under 'add item' rather than the ReSharper 'New from template'.

    Thursday, November 17, 2016 9:15 PM

All replies

  • My mistake.

    I have ReSharper installed and it has it's own Template mechanism - which was showing templates that I had added to it, the new item template was correctly added but is shown under 'add item' rather than the ReSharper 'New from template'.

    Thursday, November 17, 2016 9:15 PM
  • Hi ellipsisware,

    Welcome to the MSDN forum.

    I'm so glad to hear that your issue is solved and thank you very much for your sharing, it will help other community members who have the same or similar issue.

    BTW, if you think your reply is helpful, please mark it as answer and that will help them to easier search this solution.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 18, 2016 1:32 AM
    Moderator