locked
Sampling/Instrumention does not work if I logged on as a restricted user.

    Question

  • I'm now evaluating Visual Studio 2005 Team Suite RC and have problem with performance sampling feature.
    When I logged on as a restricted user, launching sampling failed due to the following error:

    Performance automation returned the following error: : Error VSP1398 : The monitor was unable to start the kernel mode driver (VSPerfDrv.sys).  アクセスが拒否されました。  Profiling cannot continue.
    PRF0010: Launch Aborted - Unable to start vsperfmon.exe
    Performance automation returned the following error: : Error VSP1341 : Could not start logging engine.  Shutting down.
    Profiler exited
    Error VSP1712 : Unknown file type.
    PRF0025: No data was collected.

    "アクセスが拒否されました。" actually means "Access Denied" But I'm not sure what's the exact phrase used in the english version of Windows.

    The user account is member of the following groups:

    Debugger Users
    Network Configuration Operators
    Remote Desktop Users
    Users
    VS Developers

    What can I do or is it a bug of VS 2005?

    Thanks in advance,
    Saturday, October 08, 2005 2:42 PM

Answers

  • Munjal,

    In spite of your kind help, I'm still with the problem.
    I've done what you've mentioned and now vsperfcmd shows the following information:

    C:\Program Files\Microsoft Visual Studio 8\Team Tools\Performance Tools>vsperfcmd /driver:status
    Microsoft (R) VSPerf Command Version 8.0.50727 x86
    Copyright (C) Microsoft Corp. All rights reserved.

    VSPerfDrv is installed but stopped.
    Autostart is disabled.
    The following users and groups are authorized to use the driver:
    ESPRESSO\kawasaki (S-1-5-21-725345543-746137067-1343024091-1003)
    NT AUTHORITY\SYSTEM (S-1-5-18)
    BUILTIN\Administrators (S-1-5-32-544)

    The target user account is the first one, ESPRESSO\kawasaki and it seems that the user is successfully authorized.

    I'm reading information on msdn2.microsoft.com but there're no resources about how to recover from such kind of errors and I have no way to recover from the error by myself now.

    How can I do next?

    Thanks,

    Monday, October 10, 2005 2:43 PM

All replies

  • Hi Takashi,

    You need to give access to that user access to the driver. Here is how you do it:

    Log in as an admin user
    Open a VS command prompt
    Add %VSINSTALLDIR%\Team Tools\Performance Tools to the path
    vsperfcmd /driver:adduser,<user-name>. The <user-name> can obviously also be <domain>\<user-name>
    Now log off, log on as limited user and do the profiling.

    Let me know if you face any problems doing this.

    -Munjal (MS)

    Sunday, October 09, 2005 9:05 PM
  • Munjal,

    In spite of your kind help, I'm still with the problem.
    I've done what you've mentioned and now vsperfcmd shows the following information:

    C:\Program Files\Microsoft Visual Studio 8\Team Tools\Performance Tools>vsperfcmd /driver:status
    Microsoft (R) VSPerf Command Version 8.0.50727 x86
    Copyright (C) Microsoft Corp. All rights reserved.

    VSPerfDrv is installed but stopped.
    Autostart is disabled.
    The following users and groups are authorized to use the driver:
    ESPRESSO\kawasaki (S-1-5-21-725345543-746137067-1343024091-1003)
    NT AUTHORITY\SYSTEM (S-1-5-18)
    BUILTIN\Administrators (S-1-5-32-544)

    The target user account is the first one, ESPRESSO\kawasaki and it seems that the user is successfully authorized.

    I'm reading information on msdn2.microsoft.com but there're no resources about how to recover from such kind of errors and I have no way to recover from the error by myself now.

    How can I do next?

    Thanks,

    Monday, October 10, 2005 2:43 PM
  • Oops, I forgot to mention one more thing: enable driver autostart from an admin login by;

    vsperfcmd -driver:autostart,on

    This will start the driver automatically when the non-admin user logs in.

    Let me know of any problems.

    -Munjal
    Monday, October 10, 2005 10:07 PM
  • Munjal,

    Now it works!

    But the MSDN documentation is poor and I could not understand why I set autostart for the driver.

    Thanks a lot,

    Takashi Kawasaki

    Tuesday, October 11, 2005 2:15 AM
  • Thanks for pointing that out; we will work on getting these details in the documentation during doc refresh.

    -Munjal (MS)

    Tuesday, October 11, 2005 11:38 PM
  • I had a similiar problem after installing Visual Studio 2008 on the same system as 2005.

    After trying get Visual Studio 2008's performance tools to work, it kept reporting that the file, "VSPerfDrv90 is not installed" I finally found a solution. It turns out on the DVD there's a seperate installer called, "vs_profiler.exe". Installing this resolves the problem(s)...[See blog post for furthur information].


    Thursday, April 10, 2008 1:24 AM
  • Sorry for digging an old topic up. I am experaincing the same issue but I can`t seem to solve it.

    every time I try adding a user for the driver I get the following error.


    "VSP1452 : unable to add user *** to VSPerfDrv9- device object/ The data is invalid".

    I am not sure what "the data is invalid" is about, the user name is correct.

    Any one any ideas?


    Update:

    fixed
    vsperfcmd /admin:security,allow,sampleprofiling,<domain/user>
    Monday, March 08, 2010 10:10 AM