none
Opening vs2008 solution file in vs2010 - Framework targeting issue RRS feed

  • Question

  • Hey guys,

    I am opening a vs2008 .sln file inside vs2010 - the conversion wizard shows up, and it goes through with no errors other than a pop up warning me that this solution needs .Net Framework 3.5 and that it is "not installed on this machine" - I chose to target it to .Net Framework 4.0 and to try to switch it later as an option.

    I then bring up Properties - >Application -> Target Framework and in the dropdown, .Net Framework 3.5 is not listed - which is strange since in "Add or Remove Programs" I can see .Net Framework 3.5 is installed on my machine.

    How can I get Framework 3.5 to show up in the dropdown so I can target this project to that framework?

    Can't say I've ever done this, so I'm pretty sure I'm doing something wrong.

     

    Update: I tried Method #1 here (http://blogs.msdn.com/b/robvi/archive/2004/02/17/75272.aspx) and I cannot see v3.5 - so where did it go? I'm confused why it is not in my registry but shows up in "Add or Remove Programs" list...

    Thanks

    • Edited by ck_technology Wednesday, September 22, 2010 9:33 PM new data
    Wednesday, September 22, 2010 8:52 PM

Answers