none
ReportViewer retrieves data correctly but doesn't show it RRS feed

  • Question

  • I'm trying to make a ReportViewer work but with no success. I have a button which should refresh the ReportViewer - the button sends parameters (filters) to the ObjectDataSource (report's source of data)SelectMethod. After that I call the report's Refresh method.

    What happens is the following - the layout of the report doesn't change (I still see non filtered data) but if I export the data to Excel or PDF, it gives me correct (filtered) data. Any ideas how to solve this? Also, if I try to navigate, I get the Page is out of scope (or sth like that) error. It's clear that the report 'knows' about the new dataset but doesn't show it!

    Has any of you had the similar problem?

    Edit: Have UpdatePanels on the page. If I remove them, everything works like a charm. How can I make it work WITH UpdatePanels on the page?

    Monday, March 2, 2009 12:11 PM

Answers

  • The current version of the report viewer is not supported in an UpdatePanel.  The report viewer will experience a number of problem, some more subtle than others.  The next release of the viewer will have full support for ASP.Net AJAX.
    • Marked as answer by Sara4 Tuesday, March 3, 2009 7:00 PM
    Tuesday, March 3, 2009 4:00 PM
    Moderator

All replies

  • The current version of the report viewer is not supported in an UpdatePanel.  The report viewer will experience a number of problem, some more subtle than others.  The next release of the viewer will have full support for ASP.Net AJAX.
    • Marked as answer by Sara4 Tuesday, March 3, 2009 7:00 PM
    Tuesday, March 3, 2009 4:00 PM
    Moderator
  • Brian, thank you very much for confirming my doubts. Earlier today I deleted the UpdatePanel from the page because I realized that there are some serious problems. You confirming my decision is appreciated :) .
    Tuesday, March 3, 2009 7:00 PM