none
Config error RRS feed

  • Question

  • I have a site, 1stSigBdeAssn.org, that works with no problem. When I show this site in a Browser I get the following error:

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

     

    Line 33:             during development.

    Line 34:         -->

    Line 35:     <roleManager defaultProvider="AspNetWindowsTokenRoleProvider"/>

    Line 36:     <compilation debug="true" targetFramework="4.0"/>

    Line 37:     <!--


    Source File: E:\brigade web\web\web.config    Line: 35

    I have made sure that the computer files, Master, CSS, Index and Config are identical to those on the Server.

     

    Hat can my problem be?


    Merv
    Tuesday, September 13, 2011 2:19 AM

Answers

  • You haven't said which version of IIS you are using. (The answer would be different.)

    Regardless, this isn't an IIS forum, and you might have a lot better luck going to the forum and tutorials appropriate for your version of IIS and asking there how to configure your sites in IIS.  Scott gave you two links in an earlier post, one for IIS6, one for IIS7, as starting points.

    • Marked as answer by Merv Norton Sunday, October 23, 2011 2:09 AM
    Tuesday, October 11, 2011 7:53 PM

All replies

  • Please clarify when you are getting this error.   Running the site where, on what server?

    Tuesday, September 13, 2011 2:57 AM
  • "I have a site, 1stSigBdeAssn.org, that works with no problem."
    "When I show this site in a Browser I get the following error:"

    Well, which is it? Does the site work without a problem, or does it throw an error when opened? You can't have it both ways.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Tuesday, September 13, 2011 4:13 AM
  • Given that the live site appears to work I'm assuming that you can't get it to run on your local machine. Please confirm.

    The first part of the error message may be the clue. "This error can be caused by a virtual directory not being configured as an application in IIS".

    How are you previewing the site? Via the development server? (Site - Site Settings - Preview).If this is the case, I'm not sure the dev server supports the ASP.Net Membership system and you may need to use IIS. If you are already using IIS, then try setting the virtual directory as an application as suggested.


    Ian Haynes

    EW V4 Add-Ins
    EW resources, hints and tips
    • Edited by Ian Haynes Tuesday, September 13, 2011 9:40 AM
    Tuesday, September 13, 2011 9:39 AM
  • The web site on the internet works with no problem. The web site when viewed on my browser from Expression Web 4 gives thew error message. Three other web sites on my computer work correctly when viewed on a browser from Expression Web 4.
    Merv
    Tuesday, September 13, 2011 6:03 PM
  • I took it that it was the local site that was giving the error. How are you previewing the site, with the xWeb development server or via IIS?

    As noted above, if you are using IIS, then try setting the virtual directory as an application as suggested in the error message.


    Ian Haynes

    EW V4 Add-Ins
    EW resources, hints and tips
    Tuesday, September 13, 2011 8:20 PM
  • I am using IIS. I do not understand what you are suggesting.

    My source code for this site is on my E Drive. I copied the entire folder over to my D Drive and it works. It now apears that the problem is limited to my E Drive.


    Merv
    Tuesday, September 13, 2011 10:47 PM
  • Interesting. Are the preview settings the same? (Site - Site Settings - Preview).

    The error message you show above has the 'Parser Error Message' at the top, which mentions setting the virtual directory as an application. To do this you need to open IIS Manager, via Control Panel - Administrative Tools - Internet Information Services (IIS) Manager. Expand the file tree in the left hand connections panel and scroll down to find your site (probably in Default Web Site'). Then right click the folder and select 'Convert to application'. You can accept the defaults given.

    Next go back to xWeb and open the site. Then go to 'Site - Site Settings - Preview'. Select the bottom option 'Preview using custom URL for this website' and enter 'http://localhost/yoursitename' . Click Apply and then try previewing the site.

    HTH


    Ian Haynes

    EW V4 Add-Ins
    EW resources, hints and tips
    Wednesday, September 14, 2011 9:12 AM
  • As I understand it, IIS settings are applied to the entire hard disk and not to specific drive partitions. As I have previously stated, I have three partitions on my hard disk, C, D and E. The problem is unique to Drive E. I have three Web sites on my computer, I have copies all three from Drive E, where all three have the stated error, to Drive D where all work perfectally.
    Merv
    Wednesday, September 14, 2011 4:15 PM
  • Merv, I'm not sure what IIS settings you are referring to, but defining an application is done at the folder level, typically the site's root folder, not for the entire drive.
    Wednesday, September 14, 2011 5:58 PM
  • You need to be more specific on what I need to check
    Merv
    Wednesday, September 14, 2011 6:37 PM
  • You need to be more specific on what I need to check
    Merv


    Read this

    http://www.serverintellect.com/support/iis6/virtual-directory-app.aspx

    and in particular, this


    No offense, Merv, but you clearly do not know what you are doing with respect to ASP.NET site management. You need to read up and understand the relationships of physical and virtual directories in IIS, and what it means to set a virtual directory as application.

    cheers,
    scott

    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Edited by paladyn Wednesday, September 14, 2011 7:51 PM
    Wednesday, September 14, 2011 7:50 PM
  • IIS is machine/OS installation specific (not drive or partition) so it sounds like the settings in IIS relate to your drive D: which is why the sites don't work as you expect when copied to and viewed from the other drives.
    Ian Haynes

    EW V4 Add-Ins
    EW resources, hints and tips
    Thursday, September 15, 2011 7:38 AM
  • I have gone to IIS, selected Sites and then selected Default Site which then displays Default Site Home. This display contains three sections, ASP.NET, IIS and Management.  There is nothing that resembles any of my web sites. What am I missing?
    Merv
    Tuesday, October 11, 2011 7:44 PM
  • You haven't said which version of IIS you are using. (The answer would be different.)

    Regardless, this isn't an IIS forum, and you might have a lot better luck going to the forum and tutorials appropriate for your version of IIS and asking there how to configure your sites in IIS.  Scott gave you two links in an earlier post, one for IIS6, one for IIS7, as starting points.

    • Marked as answer by Merv Norton Sunday, October 23, 2011 2:09 AM
    Tuesday, October 11, 2011 7:53 PM