locked
FTP server keeps saying "Connection closed by remote host" RRS feed

  • Question

  • User-1585123517 posted

     Hi

    I'm trying to setup an FTP sevrer in iis 7.

     I've unblocked the port 21 in the firewall and set it to allow anonymous access in order to test it out.

    If i try to access it from the same machine i get Connection closed by remote host.  Any ideas as to why.  Everywhere i've looked so far says it is a firewall issue.  If so what is it i'm meant to do?

     I'm running Windows server 2008.

    Thanks

    Si

    Thursday, April 22, 2010 9:52 AM

All replies

  • User-1585123517 posted

    I've realised i get an error when i test the settings in IIS:

    Authorization: Cannot verify access to path

    Ther server is configured to use pass-through authetication with a built-in account to access the specified physical path.  However, IIS Manager cannot verify whether the built-in account has access bla bla bla....

    I have check the application pool and it is using NetworkService, which has read and write access to the folder.

    Friday, April 23, 2010 4:35 AM
  • User-1585123517 posted

     Ok i've got past these errors by starting from scratch and creating the site without ananymous users.

     Have setup Isolated users and have managed to login.  However now it just hangs without displaying a list of files.  I have Sysinternals Process Monitor running and that hasn['t found any errors.

     The ftp error is 550: Data channel timed out

     How can i find whats wrong with this?

    Friday, April 23, 2010 7:07 AM
  • User744767459 posted

    Hi,

    FTP protocol uses a minimum of two connections during a session. TCP port 21 is used on the server for the control connection, but the data connection is determined by the method that the client uses to connect to the server.

    Could you please follow the procedure in the article below to configure the firewall settings, then test again?

    Configuring FTP Firewall Settings

    http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/

    Thanks.

    Tuesday, April 27, 2010 1:20 AM
  • User-1585123517 posted

    I've already read that tutorial. It wasn't anything to do with the firewall.  I turned it off completely and it was still having the same problem.  In the end i gave up and created a Ubuntu VM with proftpd.  However i expect i'll be back to IIS after we switch to using active directory.  I'll take another stab at this and see what happens.  Thanks for your reply.

    Tuesday, April 27, 2010 3:16 AM
  • User317860069 posted
    In my case, it was the binding. After setting it to All Unassigned it works.
    Tuesday, May 11, 2010 7:42 AM
  • User-408987462 posted

    I had the same issue. In my case I had to remove any FTP settings from applicationHost.config and recreate the site from scratch.

    Wednesday, March 10, 2021 9:31 PM