none
Known issues concering installation of .NET framework 1.1 when .NET framework 2.0 is already installed? RRS feed

  • Question

  • Are there any known issues concerning installation of .NET Framework 1.1sp1 when .NET framework 2.0 is already installed?

     

    All of our client pcs already have .NET framework 2.0 installed.  We are in the process of upgrading one of our software packages; the upgraded version requires .NET framework 1.1sp1.  In the software's installation instructions, it has a warning to uninstall 2.0 before installing 1.1.  If at all possible, I would like to install 1.1 without uninstalling 2.0.

     

    All of our clients are currently running WinXP.

    Monday, February 25, 2008 1:36 PM

Answers

  • First of all, in general .NET Framework 2.0 is back compatible with 1.1, that is to say if there is no CLR runtime v1.1 being found, it will use v2.0 instead. You'd better give a test on it to confirm the compatiblity of your application.

    Next, one don't need to uninstall .NET 2.0 before installing .NET 1.1.

    Then, if both are installed, they will co-exist on one machine, no problem.

     

    Thanks

    Wednesday, February 27, 2008 3:47 AM