Why IIS 7.5 cannot respond correct content type? RRS feed

  • Question

  • User-1995382194 posted

    I've mobile web site that hosted at IIS 7.5 as web site. I tested at two environments (Development and UAT) on same source code. But the respond is different content is different. I checked at application pool, web site setting, web.config for my website and also for IIS's web.config, all are same.

    On Development environment respond the content type is "text/vnd.wap.wml; charset=utf-8" and UAT environment respond the content type is "text/html; charset=utf-8"

    My Problem is, When I browse from My handheld device Motorola i615's Openwave browse, on Development can work properly at the mobile page and UAT cannot see any list item that bind at the mobile form.

    Do I miss out any configuration on IIS?

    N.B; I already tried to compare Browsers under the following folders - C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\Browsers - C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\Browsers - Compared MIMIE types on Both servers Both server has no different setting.

    Please help me.

    Thanks & Regards, Phyoe

    Monday, April 7, 2014 3:56 AM

All replies

  • User-902516579 posted


    You might want to check the 'Ordered List' of Handler Mappings on both servers to make sure the same is handling the requests to both.

    HTH, Benjamin

    Monday, April 7, 2014 6:02 AM
  • User-1454326058 posted

    Hi phyoe2004,

    Please set the content type in your code.

    For example:

    Response.ContentType = "text/vnd.wap.wml";
                url: 'XXX',
                type: "POST",
                data: [your data],
                contentType: "application/json",
                success: function (dataview, textStatus) {
                error: function () {

    There is a thread that can help you:

    # Response.ContentType possible values



    Best Regards

    Tuesday, April 8, 2014 2:29 AM
  • User-1995382194 posted

    Dear Chen, 

    Thanks you very much for your reply. Actually, my project has been deployed at Production long ago and working fine. Last a few days ago we realize that issue cause most of the user switch to PDA. So I also don't want to touch for existing code. 



    Tuesday, April 8, 2014 11:11 PM
  • User-1995382194 posted

    Dear Parkinsville,

    Thanks for your reply and base on your message I checked on both server and I found out two point on UAT and DEV environments.

    • Service Pack Update
    1. UAT Server has been updated with Service Pack (Microsoft Windows Server Version 6.1 (Build 7601: Service Pack 1), Internet Information Services (Version 7.5.7600.16385) and there has recently updated.
    2. DEV Server has no update (Microsoft Windows Server Version 6.1(Build 7600), Internet Information Services (Version 7.5.7600.16385)

    *** Will it be cause by Windows Update?

    • These items are the missing on Handler Mapping Feature at UAT server
    1. xoml-ISAPI-2.0
    2. xoml-integrated
    3. xoml-64-ISAPI-2.0
    4. TRACEVerbHandler
    5. TraceHandler-Integrated-4.0
    6. TraceHandler-Integrated
    7. SVC-ISAPI-4.0-64bit
    8. SVC-ISAPI-4.0-32bit
    9. SVC-ISAPI-2.0-64
    10. SVC-ISAPI-2.0
    11. SVC-Integrated-4.0
    12. SVC-Integrated
    13. rules-ISAPI-2.0
    14. rules-Integrated
    15. rules-64-ISAPI-2.0

    Is it cause of them? I tried to add them into UAT but some are cannot add because cannot find such dll at UAT server.

    Thanks & Regards,


    Tuesday, April 8, 2014 11:26 PM
  • User-1454326058 posted

    Hi phyoe,

    Please check whether there is the text/vnd.wap.wml in the MIME Types.


    Best Regards

    Wednesday, April 9, 2014 3:39 AM
  • User-1995382194 posted

    Dear Chen,

    Thanks for your reply.

    Yes, I found it at the MIME type. Is there any configuration do I need to check? Cause it is really strange issue that I face. That project is working long time ago and suddently happen this. 

    Thanks & Regards,


    Wednesday, April 9, 2014 4:18 AM