none
Occassional error

    Question

  • On a semi-regular basis, I get the error listed below.  I have setup a file based web with .net 3.5 sp1 beta1.  I have setup a VPC session with vs.net 2008.  The error doesn't occur all the time.  I've only seen it when I call out the .svc service.  When I compile with the IDE, I get NO errors.  I have no idea where this App_Web_yxt90og4 assembly is coming from.  Does anyone have any suggestions regarding how to resolve this issue?  Is there something somewhere looking for a file in App_Web folder?  The folder doesn't exist in this project and this project has worked.

     

    Could not load file or assembly 'App_Web_yxt90og4, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

     

    [FileNotFoundException: Could not load file or assembly 'App_Web_yxt90og4, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.]
       System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
       System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43
       System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +127
       System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142
       System.Reflection.Assembly.Load(String assemblyString) +28
       System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses) +162
       System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +11671836
       System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +42
       System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +479

    [ServiceActivationException: The service '/Web/OrderItemDataService.svc' cannot be activated due to an exception during compilation.  The exception message is: Could not load file or assembly 'App_Web_yxt90og4, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified..]
       System.ServiceModel.AsyncResult.End(IAsyncResult result) +11544570
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +194
       System.ServiceModel.Activation.HostedHttpRequestAsyncResult.ExecuteSynchronous(HttpApplication context, Boolean flowContext) +176
       System.ServiceModel.Activation.HttpHandler.ProcessRequest(HttpContext context) +23
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +181
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

    Saturday, May 17, 2008 1:52 PM

Answers

  •  

    Hi wally ,

     Try clearing out the temporary Asp.net files folder to get rid of any compiled old copies of your service code.

     You can find it at :

     

    %windir%\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

     

    Let us know if this helps get rid of the occasional error.

     

    Thanks,

    Phani

    Sunday, May 18, 2008 3:41 AM
    Moderator

All replies

  •  

    Hi wally ,

     Try clearing out the temporary Asp.net files folder to get rid of any compiled old copies of your service code.

     You can find it at :

     

    %windir%\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

     

    Let us know if this helps get rid of the occasional error.

     

    Thanks,

    Phani

    Sunday, May 18, 2008 3:41 AM
    Moderator
  • Is there a better (more permanent) way to solve this issue?  This is happening in our live environment - so there's downtime every time this happens (from the time the site goes down till the time i can get in there and whack the temp files).

    the relevant app info is silverlight 3 / wcf / .net 3.5

    much appreciated.

    Kevin

    Monday, December 21, 2009 6:46 PM