locked
HOWTO: Install older versions of Xamarin software RRS feed

  • Question

  • User1044 posted

    If, for whatever reason, you want to install an older version of Xamarin Studio, Xamarin.iOS, Xamarin.Android or Xamarin.Mac...

    Go to https://store.xamarin.com/account/my/subscription/downloads, making sure to login, and you'll see a screen like the attached screenshot:

    Under each product, there is a combo box for both Windows and Mac which each contain a list of older releases. Simply select one and your browser will begin the download.

    Hope that helps,

    Jeff

    Wednesday, November 13, 2013 5:51 PM

All replies

  • User28224 posted

    This is great, but I can only see Xamarin Studio on my account page, there are no dropdown boxes for Xamarin.Android, Xamarin.iOS, or Xamarin Mac. How do we download these if they don't appear? I am on a trial, and am having all sorts of problems with the latest version of Xamarin.Android (4.10.1) on Visual Studio, and can't find how to install the previous version. So I am stuck. Help please.

    Tuesday, December 3, 2013 11:26 PM
  • User28 posted

    @RT: older versions are only shown for customers who have purchased them. If you're having problems with your trial and need an older version I suggest you email support.

    Wednesday, December 4, 2013 7:43 PM
  • User31867 posted

    I want to take trial of Xamarin and what I have is MacBook with 10.6.3 OS. Is there any way so that I can install Xamarin studio on it?

    Thursday, December 12, 2013 5:25 AM
  • User1044 posted

    No, you need at least OS X 10.8 to even install a current version of Xcode in order to get the current iOS SDKs, so installing on 10.6.3 would be pointless.

    Currently, Xamarin Studio (4.2) runs on OS X 10.7 and possibly as old as 10.6.8, but it has never been tested on anything older than 10.6.8 in the past 2 years of development.

    (I was developing on 10.6.8 until about 6 months ago)

    Thursday, December 12, 2013 1:38 PM
  • User32159 posted

    I have downloaded XamarinInstaller.exe and tried to install xamarin IDE for Windows XP by double clicking it. A pop up window did come out and I clicked on Continue button thereon. Next nothing happened. I dont find it to be installed!! Please help.

    Friday, December 13, 2013 11:42 PM
  • User32338 posted

    Have you got any good solutions to the problem?

    Monday, December 16, 2013 10:51 AM
  • User1044 posted

    If you go to the URL I mention in my post above, you can download the individual installers. That might work better for you.

    Monday, December 16, 2013 2:15 PM
  • User45752 posted

    how to downlaod 4.0.12 version of xamarin.please give url of download.

    Thursday, April 3, 2014 7:14 AM
  • User1044 posted

    You can download Xamarin Studio 4.0.12 from here: http://download.xamarin.com/studio/Mac/XamarinStudio-4.0.12-3.dmg

    Why do you want to use such an old version?

    Thursday, April 3, 2014 3:24 PM
  • User309 posted

    It seems to show 5 or 6 latest version. I can't renew for now and the problem is I can't find anywhere the last iOS version I can download and install with my subscription. Thanks in advance for your guidance.

    Friday, April 18, 2014 9:19 AM
  • User1044 posted

    Hi @ROLision?,

    If you don't see a version in the Xamarin.iOS dropdown that you are looking for, you should probably send an email to support@xamarin.com. We keep an archive of all past releases, so the support team should be able to get you any past release that you desire - even if you aren't able to renew (I'm pretty sure that when you buy a Xamarin license for a product, that you are at least entitled to any release made during the time period you had a license).

    Perhaps you can suggest to the support team that the web interface provide more options as well, for people in the same sort of situation that you are in.

    Good luck and I hope my suggestion is helpful.

    Friday, April 18, 2014 3:28 PM
  • User7903 posted

    How I can download the version 4.10.01073 Xamarin.Android for Visual Studio 2010? Please give me a URL to download. Thanks for advance.

    Monday, April 21, 2014 6:55 PM
  • User1044 posted

    If you don't see the version you are looking for on the website, there's nothing I can do for you. You'll have to email support@xamarin.com and ask.

    Monday, April 21, 2014 7:00 PM
  • User19462 posted

    What about specific builds in Alpha Channel? I'm having trouble seeing my Droid device from the XS IDE since 5.1 (build 462) on my iMac. Still working fine on the MacBook on 5.0.1 (build 3). Is it possible to select a specific build in Alpha channel? I'm rolling back to Stable channel on the iMac now to see whether this fixes it. My problem is I need Alpha channel in order to use mvvmcross via nuget. If rolling back fixes the problem I'll report it in the XS forum...

    Monday, June 16, 2014 12:33 AM
  • User1044 posted

    @doogli?

    I'm not sure what you are asking. If you don't want to run the 5.1 Alpha, you can switch back to the 5.0.1 stable version by simply switching to the Stable update channel.

    Monday, June 16, 2014 4:17 PM
  • User8658 posted

    I currently have an IOS Business plan and would like to start testing and using Android. Is there a way I can install the Free Starter Addition along side my Business edition so I can test Android? Or is there a way I can install different versions on the same MacBook? Thank you

    Tuesday, August 5, 2014 7:45 PM
  • User28 posted

    @PaulKelly the Xamarin.Android installer and Xamarin.iOS installer are separate on Mac (though the main installer from xamarin.com downloads and installs both of them by default). If you install XA but don't have an XA license, it will behave as Starter. Your XI license won't affect XA at all.

    Thursday, August 7, 2014 2:19 AM
  • User37569 posted

    hi sir, can u give me a link to the previous xamarin version 3.1, please.

    Thursday, August 7, 2014 8:21 PM
  • User49472 posted

    @mhutch The title on XStudio 5.3 release notes page refers to XStudio 5.2.

    developer.xamarin.com/releases/studio/xamarin.studio5.3/xamarin.studio5.3/

    Thursday, August 14, 2014 6:57 PM
  • User112 posted

    It'd be nice to have an option to pick beta versions as well, not only stable ones.

    Thursday, September 11, 2014 6:59 AM
  • User49775 posted

    It seems i need to go all the way back to 3.3.47 to not get the datetime.now bugg (http://forums.xamarin.com/discussion/25093/dst-daylightsavingtime-issue-for-datetime-now). This is not in the list (only goes back to 9th of september). How to get those easily? I have already mailed support, but not heard back.

    Thursday, October 2, 2014 10:18 AM
  • User68204 posted

    Why do you want to use such an old version?

    Because the "new" versions aren't any good. For instance, you removed "Deploy to Web" somewhere around 5.1. Every version after that is basically garbage for our needs.

    Thursday, January 22, 2015 10:04 PM
  • User72117 posted

    Where do we find the archived versions?

    Monday, May 18, 2015 2:33 PM
  • User64233 posted

    On the Mac OS, you can install Xamarin.Android and Xamarin.iOS separately, allowing you to freeze the version of one platform while updating the other.

    On Windows, it appears that one installer installs both Xamarin.Android and Xamarin.iOS, which means that if you want to update one, you have to update both (or if you want to downgrade one, you have to downgrade both). Is there a way around this on Windows?

    Thursday, May 21, 2015 8:43 AM
  • User1044 posted

    @nick5454 You'll have to contact support@xamarin.com and ask them for a specific version (they'll have links to the archives).

    Monday, May 25, 2015 1:13 AM
  • User1044 posted

    @Bosco I don't know. I think on Windows, the Visual Studio plugins are a combined plugin, so possibly not. You could ask support@xamarin.com and they can get you a more definite answer.

    Monday, May 25, 2015 1:14 AM
  • User31218 posted

    I understand this is an old discussion thread, but it's the most relevant one.

    We found the recent update to Xamarin 5.9.7 causes an issue with code signing. We need to rollback to an older version of Xamarin platform. Form my account's download page, I only see older versions of Xamarin Studio, but not the entire platform (no other components such as Xamarin.iOS or Xamarin.Android).

    What we need is a complete platform installation package for a previous version. Where can I get it?

    Thanks, Jun

    Friday, September 25, 2015 4:11 PM
  • User176538 posted

    I am looking for a version of xamerin supported by mac osx 10.6.8

    Friday, November 27, 2015 7:52 PM
  • User1044 posted

    @richardgrant Ouch. That is quite an old version.

    Unfortunately I think you are out of luck. I'm sure we have some older versions of our products that will work on that version of OS X, but they won't do you much good because they'll only support really old versions of iOS and/or Android and at least in the case of iOS, you won't be able to submit to the App Store because Apple will only accept builds using the latest version of Xcode (which is also not supported on OS X 10.6.8).

    Monday, November 30, 2015 7:09 PM
  • User137053 posted

    I think it is very incredible that it is not possible to find separated components of the Xamarin tools (like Xamarin Studio stand alone or Xamarin Android Player stand alone) for older versions. I am getting crazy trying to find the versions that I need, and I am starting to think that this is not possible. At our company we have had a problem with newer version which could not be fixed and we decided to stitch to an older version of the framework, the IDE and so on. Please make the fruition of such resources possible and easy to find.

    Thursday, December 17, 2015 2:20 PM
  • User251381 posted

    how i can install xamarin studio on windows without visual studio please reply

    Monday, August 22, 2016 5:24 PM
  • User25369 posted

    I need to download the Xamarin 6.0.2 but I don't find it. Is it possible?

    Monday, September 19, 2016 7:34 AM
  • User1044 posted

    Go to https://store.xamarin.com, login, click on your name in the upper-right corner, select "Install" from the drop-down menu, and then you'll see each of our products. In the Xamarin Studio section, select the version you want.

    Monday, September 19, 2016 8:20 PM
  • User104155 posted

    I was looking for Xamarin.iOS 9.4.0.0 and Xamarin.Droid 6.0.0.34 for OS X, does anyone know where I can find them?

    They don't appear in the Downloads page, so I tried "guessing" their download links but had no success.

    In case I have to contact support in order to obtain the download links, how can I do that? My subscription in indie.

    Tuesday, October 25, 2016 2:03 PM
  • User30998 posted

    The list for me ends at 6.0, but I need 5.10.3.

    Thursday, October 27, 2016 7:16 AM
  • User13824 posted

    See the knowledge base article on this topic for additional information about acquiring older versions:

    https://kb.xamarin.com/customer/portal/articles/1699777-how-do-i-downgrade-to-an-older-version-

    Friday, October 28, 2016 12:01 AM
  • User325195 posted

    Just a small thing--the version of Xamarin Studio for Windows listed today (May 20 2017) as latest is 6.3 at May 10 at this link: https://dl.xamarin.com/MonoDevelop/Windows/XamarinStudio-6.3.0.864.msi but that link refers to nothing. However the April 6 version also 6.3 does exist.

    Saturday, May 20, 2017 10:30 PM
  • User325964 posted

    can it run in visual studio 2010 ?

    Wednesday, May 24, 2017 6:30 AM
  • User280953 posted

    I need to install xamarin on osx 10.9.5 . I couldn't get any link listed above working. Any tip ?

    Tuesday, June 27, 2017 2:31 AM
  • User280953 posted

    Forgot to mention, I paid for xamarin university do I need to purchase any license to use xamarin on osx 10.9.5 ?

    Tuesday, June 27, 2017 2:44 AM
  • User366719 posted

    hi i am using visual studio 2015 update , how can i manually install xamarin version 4.8.0. right now when i am installing it by modify visual studio 2015 and installing cross platform it automatically downloads me the version 4.10. please help.... Thanks in advance :)

    Thursday, May 31, 2018 3:07 PM
  • User366719 posted

    Hello guys, how i can give detect a tap event inside a particular method on the basis of which i can fire my event. example : if i have three tap events A,B,C and one method D , so in method D I want to detect when A is Tapped and same for B and C , depending on which i have to provide my functionality. Thanks in Advance :)

    Thursday, June 7, 2018 10:00 AM