none
Microsoft.VisualStudio.Tools.Office.Runtime.Internal ? RRS feed

  • Question

  • I have an Outlook add-in which fails to load. When I enabled fusion logging it appears to be unable to load:
    Microsoft.VisualStudio.Tools.Office.Runtime.Internal

    Can someone advise me where this dll resides? It looks like a library that should be part of the VSTO runtime?

     

    *** Assembly Binder Log Entry (3/13/2011 @ 11:24:35 AM) ***
    The operation failed.
    Bind result: hr = 0x80070002. The system cannot find the file specified.
    Assembly manager loaded from: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
    Running under executable C:\Program Files (x86)\Microsoft Office\Office14\OUTLOOK.EXE
    --- A detailed error log follows. 
    === Pre-bind state information ===
    LOG: User = CONTOSO\brain
    LOG: DisplayName = Microsoft.VisualStudio.Tools.Office.Runtime.Internal, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
     (Fully-specified)
    LOG: Appbase = file:///C:/Program Files (x86)/Microsoft Office/Office14/
    LOG: Initial PrivatePath = NULL
    LOG: Dynamic Base = NULL
    LOG: Cache Base = NULL
    LOG: AppName = OUTLOOK.EXE
    Calling assembly : (Unknown).
    ===
    LOG: This bind starts in default load context.
    LOG: Download of application configuration file was attempted from file:///C:/Program Files (x86)/Microsoft Office/Office14/OUTLOOK.EXE.config.
    LOG: Configuration file C:\Program Files (x86)\Microsoft Office\Office14\OUTLOOK.EXE.config does not exist.
    LOG: No application configuration file found.
    LOG: Using host configuration file: 
    LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
    LOG: Post-policy reference: Microsoft.VisualStudio.Tools.Office.Runtime.Internal, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
    LOG: GAC Lookup was unsuccessful.
    LOG: Attempting download of new URL file:///C:/Program Files (x86)/Microsoft Office/Office14/Microsoft.VisualStudio.Tools.Office.Runtime.Internal.DLL.
    LOG: Attempting download of new URL file:///C:/Program Files (x86)/Microsoft Office/Office14/Microsoft.VisualStudio.Tools.Office.Runtime.Internal/Microsoft.VisualStudio.Tools.Office.Runtime.Internal.DLL.
    LOG: Attempting download of new URL file:///C:/Program Files (x86)/Microsoft Office/Office14/Microsoft.VisualStudio.Tools.Office.Runtime.Internal.EXE.
    LOG: Attempting download of new URL file:///C:/Program Files (x86)/Microsoft Office/Office14/Microsoft.VisualStudio.Tools.Office.Runtime.Internal/Microsoft.VisualStudio.Tools.Office.Runtime.Internal.EXE.
    LOG: All probing URLs attempted and failed.
    

     

    Sunday, March 13, 2011 6:38 PM

Answers

All replies

  • Hello,

    Thanks for posting. From that log, this add-in was developed under a machine with Office 2010 and Visual Studio 2010 installed. Right? When this issue happens? Running the add-in under VS?

    To troubleshoot add-ins load failure, please try to follow this blog to find more information: http://blogs.msdn.com/b/haahmadi/archive/2010/05/26/my-vsto-add-in-does-not-load.aspx. Then we could do some research on it.

    If you have any concern on this post, just feel free to follow up. Have a nice day.


    Bessie Zhao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 14, 2011 10:13 AM
  • Hi Bessie,
    I'm not sure what platform the add-in was developed under. I have installed it on a clean Win7 SP1 x64 with Office 2010 x32, VS2010TO Runtime x64, .Net Framewark 4 Client & Extended.

    Regards the troubleshooting step.
    I get the same bind error when I start Outlook with the VSTO_SUPRESSDISPLAYALERTS variable set.
    The add-ins LoadBehaviour is 3, and the Resilliency key is not defined.

     

     

    Monday, March 14, 2011 1:55 PM
  • Hello again,

    First, I am afraid that we need to know what are the versions of Office and Visual Studio which this add-in targets. It is because if this add-in targets Office 2003 and Visual Studio 2005, it will not work for Office 2010 32-bit. For more information, please see these resources:

    VSTO Add-In Load Failure on Outlook 2010 64-bit:
    http://social.msdn.microsoft.com/Forums/en-US/vsto/thread/7bb4d1ff-ffd1-4f14-8ac0-b2436a19a1d7.

    Running Solutions in Different Versions of Microsoft Office:
    http://msdn.microsoft.com/en-us/library/bb772080.aspx.

    Second, for the registry hive of this add-in, it would be different in Windows 7 64-bit with Office 2010 32-bit. It should be "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\application name\Addins\add-in ID". Please see the thread: http://social.msdn.microsoft.com/Forums/en-US/vsto/thread/43fbb486-8ee2-404d-9b18-3b04dee750e6/.

    Hope this post could help you more or less. Have a nice day.


    Bessie Zhao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Bessie Zhao Monday, March 21, 2011 8:20 AM
    Tuesday, March 15, 2011 10:14 AM
  • Hi Pinky and Bessie,

    Just wanted to chip in and say we're experiencing the same issue on a particular workstation (Not sure if relevant, was WinXP upgraded to Win 7) To go around this error we have resorted to cloning the VSTO runtime in the GAC. We don't like the hack, but it stopped the error.

    What we did was:

    • Go into the GAC_MSIL folder in Windows/Microsoft.NET/assembly.
    • Find the Microsoft.VisualStudio.Tools.Office.Runtime folder. Copy and paste.
    • Rename the copy as Microsoft.VisualStudio.Tools.Office.Runtime.Internal
    • Open the folder and drill down to the DLL. Then rename the DLL as Microsoft.VisualStudio.Tools.Office.Runtime.Internal.DLL

    This bypassed the issue but doesn't explain why Office is looking for the Internal.Dll (checking fusion on other installs doesn't point to internal).

     

    So the question is why is this occurring in the first place?

     

    Friday, July 15, 2011 3:55 AM
  • Hi All,

    I am also getting this issue now on a server (Windows 2003 R2 - 32bit). With Office 2010 - which the addin was developed against. The workaround supplied by Gary also worked for me however I am also unsure as to why it is required?

    Has anyone had any luck with this?

    Regards,

    Keiran.


    Tuesday, August 2, 2011 7:20 AM
  • Hi, I am also having this problem. The workaround supplied by Gary also worked for me. But why does this happen and how can we solve it by our msi. We have 1000 users so it is not an option to manually fix this.
    Thursday, October 20, 2011 4:17 PM
  • I've just come across this problem, and from what I can tell it appears that an installation of Office usually (but not always) installs the Microsoft.VisualStudio.Tools.Office.Runtime DLL (the one we would usually check for in our setup), but NOT the Microsoft.VisualStudio.Tools.Office.Runtime.Internal DLL.

    However when I ran the latest redistributable package from Microsoft it installed the Internal DLL as well. http://www.microsoft.com/download/en/details.aspx?id=20479

    So the solution would appear to be to always install the re-distributable package. Hope that helps someone.

     

    • Proposed as answer by AlbertKasdorf Thursday, April 5, 2012 12:59 PM
    Friday, November 18, 2011 12:17 PM
  • Hi,

    we have the same issue:
    - Win x86 & Office 2010 x86 works,
    - Win x64 & Office 2010 x64 works
    - Win x64 & Office 2010 x86 unable to load Microsoft.VisualStudio.Tools.Office.Runtime.Internal

    After we installed the latest "Visual Studio 2010 Tools for Office Runtime" it works.

    vstor40_x64.exe, 10.0.30319.308, 0‎3.05.2010
    vstor40_x86.exe, 10.0.30319.308, 0‎3.05.2010
    => unable to load Microsoft.VisualStudio.Tools.Office.Runtime.Internal

    vstor40_x64.exe, 10.0.31119.0, 0‎9.06.2011
    vstor40_x86.exe, 10.0.31119.0, ‎0‎9.06.2011
    => works

    Regards
    Albert Kasdorf


    Thursday, April 5, 2012 1:05 PM