locked
Unpublished items are detected on the page - occurs due to "My sites" feature and any external links RRS feed

  • Question

  • My master file will not fully publish all items. Specifically items such as these:

    <tr><td>
           <div id="smoothcontainer">
           <noscript>
           <a href="/nav.htm">Site map</a>
           </noscript>
         </div>
          </td></tr>

    Or

    <div id="headerUniteMin" style="background:#ffffff;font-size:11px;font-family:arial;padding:2px 10px;display:none;margin-bottom:8px">
        <div style="text-align:right;margin-right:5px;background:0;">
        
          <a href="sss.com/">Unite</a> <span> | </span>
          <a href="Phone" _mce_href="ssscom/">Phone" rel=nofollow>http://phonedir.uhc.com/">Phone Directory</a> <span> | </span>
          <a href="myuhc.comhttpsssss/">my.com</a>
          <span> | </span><a href="http://sss/tools/businesses/uhg_businesses.html">
          Businesses</a>
          <span> | </span><a href="sss/">Frontier</a>
          <span> | </span><a href="sss.com/">HRdirect</a>
          <span> | </span><a href="Unite" _mce_href="sss.html">Unite" rel=nofollow>http://hss.html">Unite Site Map</a>
          <span> | </span><a href="/inside/sitemap">UHN Site Map</a>
        
        </div>
        </div>

    While I publish the page; these divs show as unpublished items afterward. The second div example, doesnt even contain any images which require approval.

    I'm a bit stumped as to why these items are not publishing. The above to items do interact with Jquery scripts located in a /js folder at the root but that doe not solve for this as other non-jquery features also throw this error. Thanks for any ideas on this.




    Friday, August 12, 2011 8:47 PM

All replies

  • Hi gabrielhaukness,

    You can check for all Unpublished Items in the Page Editing Tool Bar on your SharePoint site page as the following post, and the unpublished links in your custom divs should be circled by the red dotted line.

    You need to publish/approve all these pages referenced on that page which shows the message “Unpublished items are detected on the page. View the full report in a new window”, then the message should be disappear .
    http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomization/thread/6cef196d-5b87-48bc-b784-40ad6f16e924/

    Thanks


    Regards, Daniel
    Tuesday, August 16, 2011 9:14 AM
    Moderator
  • Update: to follow on the above issue I did in fact pinpont the issue to any external link appearing as unpublished and causing any non-site collection administrator to get the "file not found" error screen.

    This includes even the My Sites OOB feature which is not linked to the root of the MOSS site but is deployed with it setup like that. Does anyone know how to solve for or workaround external links so they are not detected as unpublished? I can't believe this issue has not been documented or that the My Sites appearing as unpublished is a normal behavior of MOSS. However, I see very little written about it so Im assuming it is a shortcoming of our deployment rather than a bug of MSFT.

     


    -Gabe
    Friday, August 26, 2011 5:35 PM
  • HI,

    Try using a content editor webpart and then use these external links there.

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Saturday, August 27, 2011 8:50 AM
  • Thanks but that still doesn't solve for the My Sites feature appearing as unpublished. My Sites is part of the global content zone ms-globalbreadcrumb and you cant place that in a CEWP (can't put a content zone in a content zone). Its a default OOB feature sandwiched between Site Actions and My Links.
    -Gabe
    Monday, August 29, 2011 2:43 PM
  • Apparently the site collection got corrupted somehow. IT could not explain it but this is the only one in the farm showing external links as unpublished items. They nuked the site from the farm and created a new instance.
    -Gabe
    Tuesday, September 13, 2011 6:29 PM