none
Visual studio code brackets doesnt move down

    Question

  • when i use the normal visual studio 2015 if i type this { then a } wil automaticly put next to it en when i press enter en both move down but on visual studio code is doent want to move automaticly down 

    http://imgur.com/a/QKnOk for better understanding

    sorry for bad english

    Tuesday, December 06, 2016 2:25 PM

All replies

  • Hi dutchkiller,

    Welcome to the MSDN forum.

    Refer to your description and the share screenshot, I tried it on my VS 2015 and VS code. It looks like the VS 2015 can autocomplete the character ‘}’ after you type ‘{’ and in VS code, it need you to manual type ‘}’ after type ‘{’, right? Once you put the cursor between ‘{}’ and press Enter key, then I will get the same result as your shared screenshot.

    As I understand, the behavior of autocomplete and display ‘{}’ can help us to better to know the begin and end of one statement, it is very intellisense for our development. If you want to remove this intellisense, please go to Tools-Options-Text Editor-All Languages/ or the specific language that you want to disable, you can find the option ‘Automatic brace completion’ under Settings like the following screenshot, then you will get the same behavior as VS code.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, December 07, 2016 5:48 AM
    Moderator