locked
Visual Studio 2013 not building installer from command line RRS feed

  • Question

  • We use a build server to compile our programs automatically as our developers make changes. We are able to build our VS2008 projects (solution/installer) successfully. We are upgrading to VS2013 because they have added the installer back in, but when we try to call the "devenv" command from the command line it errors out.

    example:

    c:>"c:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv" solutionfile.sln /Build "Release|Any CPU" /Project "Project Folder/Projectfile.vdproj"

    error:

    Microsoft Visual Studio 2013 Version 12.0.21005.1.

    Copyright (C) Microsoft Corp. All rights reserved.

    ------Starting pre-build validation for project 'Project Installer' ------

    ERROR: An error occurred while validating. HRESULT = '8000000A'

    ------ Pre-build validation for project 'Project Installer' completed ------

    1>------ Build started: Project: Project Installer, Configuration: Release ------

    ========= Build: 0 succeeded, 1 failed, 24 up-to-date, 0 skipped =========

    Any help/ideas appreciated.

    Thanks.

    Thursday, May 15, 2014 4:24 PM

Answers

All replies

  • Hi,

    >>ERROR: An error occurred while validating. HRESULT = '8000000A'

    The error code you are seeing was introduced with this KB: http://support.microsoft.com/kb/2444922 (I have checked this kb and it is for visual studio 2010. And you can read too.)

    There is a race condition that sometimes used to cause hangs when building setup projects on the command line. It turned out to be an issue that was very risky to tackle, so the decision was made to return this error code (8000000A) instead.

    Considering the high risk of solving the problem, and the fact that Visual Studio Installer projects have been deprecated in Visual Studio 2010, it is very unlikely that this issue will be fixed. And Visual Studio 2013 has no either. So it is the main reason.

    Instead, there are a few recommendations on how to work around the problem:

    • Script the build process to check for this particular error message. If it appears, rebuild the setup project.
    • Attempt to automate Visual Studio to load and build the project in the IDE and not from the command line. (This one is more difficult to implement.)

    More information, please refer to http://blogs.msdn.com/b/hmahrt/archive/2012/02/10/tfs-2010-an-error-occurred-while-validating-hresult-8000000a.aspx

    and http://blogs.msdn.com/b/buckh/archive/2011/03/17/visual-studio-setup-projects-vdproj-will-not-ship-with-future-versions-of-vs.aspx

    Best reagdrs,

    • Marked as answer by Anna Cc Sunday, May 25, 2014 3:01 PM
    Friday, May 16, 2014 7:22 AM
  • Some case of such errors have been fixed in the Microsoft Visual Studio Installer Projects 1.0.0.0 for VS 2013 as mentioned here: http://visualstudiogallery.msdn.microsoft.com/9abe329c-9bba-44a1-be59-0fbf6151054d   

    But in my case, although I didn't have the error when using VS 2010's devenv.com, it failed with this error code 8000000A when using VS 2013's devenv.com, on the very same setup project... The solution was to add the registry key mentioned in the page referenced here above, I.e.:

    If you are still suffering this issue then you can try to change the DWORD value for HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0_Config\MSBuild\EnableOutOfProcBuild registry value to 0. If this doesn't exist you can create it as a DWORD.

    NB.: I had to do that for the "Default User" in the registry as well as for the "service account" running the TFS build Service...



    Valéry Letroye



    Wednesday, July 30, 2014 2:24 PM
  • The solution was to add the registry key mentioned in the page referenced here above, I.e.:

    If you are still suffering this issue then you can try to change the DWORD value for HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0_Config\MSBuild\EnableOutOfProcBuild registry value to 0. If this doesn't exist you can create it as a DWORD.

    NB.: I had to do that for the "Default User" in the registry as well as for the "service account" running the TFS build Service...


    Valéry Letroye


    That last line was the fix I needed... I found this tip on several pages already in the past few days. I should have known when I added the key in "CURRENT_USER" while I was logged on with personal domain account! I just logged on using the Build-service account and it finally solved my build-problem. Took me a few days but finally it works. Thanks.

    .NET Developer & Infrastructure Engineer.

    Monday, November 17, 2014 2:44 PM