none
Error occured while creating the biztalk port configuration file. RRS feed

  • Question

  • I am trying to create a schema for the Oracle Database Table to perform Insert. I tried using the Add Generated Item -> Consumer Adapter Service. And getting the below error

    When I clicked OK, I see the schema created. While trying to open the schema I see the other error message like

    What could be the issue can any one help out.

    Thanks


    • Edited by vdha Wednesday, August 26, 2015 12:08 PM
    Wednesday, August 26, 2015 12:07 PM

Answers

All replies

  • Hi,

    While creating the schemas and Port configuration file from "Consume Adapter Service" Wizard probably the port configuration file name is too large and hence you are getting this error.

    Rahul

    Wednesday, August 26, 2015 12:18 PM
  • I dont give any file name in Consumer Adapter Service, or there is no field to edit the filename. What should I do?
    Wednesday, August 26, 2015 12:21 PM
  • Hi Vdha,

    Please refer related thread, same issue reported earlier, it will help you to resolve your issue.

    WCF Oracle adapter Schema generation error


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, August 26, 2015 12:22 PM
    Moderator
  • Hi,

    There seems some problem with your table structure . You are getting exception "http//Microsoft.LobServices.OracleDB/2007/03/DEVLAW/Table/MACINVOICE:VENDOR_SIMPLE_TYPE" is not declared"

    Can you go to the specific column of the table and try to figure out the datatype and declaration of the columns.

    This may be the reason you are unable to generate table operation schema .

    Thanks

    Abhishek 

    Wednesday, August 26, 2015 12:49 PM
  • Hi,

    It's also posible that the wizard has not generated all the schema files properly.

    The schema that is failing, is probably importing or including other schemas that are defining the types that are failing to load.

    Check the import and include clauses in the schema, in order to find out if the related schemas are correctly imported.

    In you specific failure, check a imported schema that is using the MACINVOICE prefix.

    Regards.


    When an answer is helpful, please vote as helpful, propose as answer and/or mark as answer

    Wednesday, August 26, 2015 12:59 PM
  • Try the following options:

    • Manually edit the namespace of the Simple Type schema to generated main schema.
    • Check the XSD Import if it is importing the correct schema

    Rahul

    • Edited by RahulS_88 Wednesday, August 26, 2015 1:05 PM
    Wednesday, August 26, 2015 1:05 PM
  • Hi Vdha,

    Please refer this link, hope you will be able to understand the issue .

    
    Hi Vdha,
    Refer this link, I hope, it will help you to resolve the issue.
    
    https://social.msdn.microsoft.com/Forums/en-US/0255e037-46d1-4a28-bdbb-0a5e048c384a/wcf-oracle-adapter-schema-generation-error?forum=biztalkgeneral
    
    Thanks,
    Chandra Kumar

    Wednesday, August 26, 2015 1:05 PM
  • I tried to verify the table datatype. But what see in the Oracle table is RUN_GROUP( CHAR (15 BYTE)), COMPANY (NUMBER (4,0)), VENDOR CHAR ( 9 BYTE)

    I dont see like RUN_GROUP_SIMPLE_TYPE, COMPANY_SIMPLE_TYPE, VENDOR_SIMPLE_TYPE

    I am not very good at Oracle, I am not sure what is the issue., Any help?/

    Wednesday, August 26, 2015 5:00 PM
  • RahulS_88 

    Wat is the Simple Type Schema here

    Wednesday, August 26, 2015 6:13 PM
  • Hi Vdha,

    Are you trying to create schema with tables or stored proc? 

    One of the best practice to use stored procedures instead of tables for any operation associated with database. and that is one of the good practice when you deal with any database operation. 

    Please refer a very nice article
    NEW SOA CAPABILITIES IN BIZTALK SERVER 2009: WCF SQL SERVER ADAPTER

    Please refer below link for oracle documentation and better understanding.

    Oracle Application Server Adapter for Databases


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, August 26, 2015 7:40 PM
    Moderator
  • I got this issue solved. While  creating the OracleDBBinding I had to give the Binding Properties as

    Friday, August 28, 2015 11:51 AM