none
.NET 3.0 setup for 3.0 project asks for framework 3.5 install RRS feed

  • Question

  • I have a single .NET 3.0 project and a setup for it. I added .NET 3.0 setup as prerequisite. It installs fine but after it asks for the setup to download .NET 3.5. If I say no it cancels the setup and doesn't install my application. I absolutely have nothing that uses .NET 3.5. Heck I don't even use any 3.0 features, only 2.0 and Web Service Enchantments 3.0 whose DLL is already in setup output. Any ideas what's wrong with this one?
    Thursday, May 29, 2008 9:22 AM

Answers

  • I assume you were using Visual Studio 2008 dealing with setup project.
    To make the setup package regard .NET 2.0 as prerequisite instead of .NET 3.5, you can go to View>>Editor>> Launch Conditions. Select ".Net Framework" under "Launch Conditions" folder, then go to the Properties window, change the "version" from 3.5(default) to 2.0 or other desired version. Rebuild the project.

    And for more setup project related question, the right forum is ClickOnce and Setup & Deployment Projects

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Wednesday, June 4, 2008 5:26 AM
    Monday, June 2, 2008 3:15 AM