locked
Unable to delete artifact from release definition RRS feed

  • Question

  • Hi all,

    I'm not sure if this is a bug; however, I'm unable to delete artifact from release definition. After I cloned release definition, I added new artifact to point to new build definition and set it as primary. Whenever, I try to delete the obsolete artifact, the save button is gray out, and I can't save release definition. I'm using TFS 2017 Update 1. Please advise.

    Best Regards,

    Andy Pham


    Best Regards, Andy Pham

    Wednesday, March 22, 2017 3:58 PM

Answers

  • Hi Andy,

    Thank you for posting here.

    It appears to be the IE browser issue;

    1.  Please check the settings for your IE browser, try to reset as default for the IE browser.
    2.  Please check the OS and IE, upgrade to the latest services packs if possible.
    3.  You can also try other browsers, eg Microsoft Edge, FireFox etc.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, March 28, 2017 9:42 AM

All replies

  • Hi Andy,

    Thank you for posting here.

    I checked this in my environment with TFS 2017 Update1 (Version 15.112.26301.0), everything works correctly.

    The ‘Save’ button is gray out means there are no any changes for the release definition, maybe you have saved the changes already… 

    Anyway, please try below things for the issue:

    1. Refresh the browser to check the ‘Save’ button.
    2. Try to clean the caches of the browser, close and reopen the browser, then check the issue again.
    3. Try to create a new release definition then clone, change the artifacts source to check the issue.
    4. Try to check the issues in another browser, eg Chrome.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 23, 2017 6:15 AM
  • I can reproduce this issue on 3 different computers with IE 11. It is working fine on Chrome. Thanks

    Best Regards,

    Andy Pham


    Best Regards, Andy Pham

    Thursday, March 23, 2017 4:35 PM
  • Hi Andy,

    Thank you for posting here.

    You can also try to reboot the TFS machine, then check the IE again.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 24, 2017 2:22 AM
  • Hi Andy,

    Thank you for posting here.

    You can also try to reboot the TFS machine, then check the IE again.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    I did clear caches and reboot TFS server, my workstation but no luck on IE 11

    Best Regards,

    Andy Pham


    Best Regards, Andy Pham

    Monday, March 27, 2017 4:30 PM
  • Hi Andy,

    Thank you for posting here.

    It appears to be the IE browser issue;

    1.  Please check the settings for your IE browser, try to reset as default for the IE browser.
    2.  Please check the OS and IE, upgrade to the latest services packs if possible.
    3.  You can also try other browsers, eg Microsoft Edge, FireFox etc.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, March 28, 2017 9:42 AM
  • Hi Andy,

    Thank you for posting here.

    It appears to be the IE browser issue;

    1.  Please check the settings for your IE browser, try to reset as default for the IE browser.
    2.  Please check the OS and IE, upgrade to the latest services packs if possible.
    3.  You can also try other browsers, eg Microsoft Edge, FireFox etc.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Like I mentioned it is working on Chrome. Thank so much for assisting.

    Best Regards, Andy Pham

    Tuesday, March 28, 2017 3:06 PM