locked
Tinymce not working after upgrading from 3.x to 4.9.2 RRS feed

  • Question

  • User-1548796982 posted

    hi

    i declare for tinymce 3.x EditorTemplate and work correctly(As per link: http://www.tugberkugurlu.com/archive/tinymce-html-text-editior-and-asp-net-mvc-setting-it-up-has-become-easy-with-nuget)

    But after upgrading tinymce to 4.9.2, it did not work anymore.

    What changes should I make?
    I've got a lot of different resources, but unfortunately it did not work

    Thursday, January 17, 2019 8:50 PM

All replies

  • User1520731567 posted

    Hi tadbirgaran,

    When you install-package TinyMCE.MVC.JQuery,the compiler automatically downloaded TinyMCE.MVC.JQuery(3.4.7), TinyMCE(3.4.7), TinyMCE.jQuery(3.4.7).

    The latest version of TinyMCE.MVC.JQuery is 3.4.7.

    You said you upgrading to 4.9.2,which one?

    What is error message on browser?

    Best Regards.

    Yuki Tao

    Friday, January 18, 2019 6:06 AM
  • User-1548796982 posted

    https://www.nuget.org/packages/TinyMCE/

    Friday, January 18, 2019 8:38 AM
  • User1520731567 posted

    Hi tadbirgaran,

    I try to make a demo according to your link,and I do reproduce the same issue by after upgrading from 3.x to 4.9.2.

    Maybe some data is lost during the upgrade process.

    I uninstall the Tinymce and install-package TinyMCE.MVC.JQuery again,and this time, I do not upgrade from 3.x to 4.9.2 directly.

    But The interval between my upgraded version is very small.

    For example:

    3.4.7 ->4.0.0->4.5.0->4.7.0-4.9.2

    Now it works fine.

    I suggest you could try this method.

    Best Regards.

    Yuki Tao

    Tuesday, January 22, 2019 8:04 AM