none
Why WinRM doesn't work in HyperV environment RRS feed

  • Question

  • Hello,

    I am getting the following message on my two virtual servers

     

    PS C:\Users\lmsrvadmin> winrm quickconfig

    WinRM already is set up to receive requests on this machine.

    WSManFault

        Message = WinRM cannot process the request. The following error occured while using Negotiate authentication: There

    is a time and/or date difference between the client and server.

    Possible causes are:

      -The user name or password specified are invalid.

      -Kerberos is used when no authentication method and no user name are specified.

      -Kerberos accepts domain user names, but not local user names.

      -The Service Principal Name (SPN) for the remote computer name and port does not exist.

      -The client and remote computers are in different domains and there is no trust between the two domains.

    After checking for the above issues, try the following:

      -Check the Event Viewer for events related to authentication.

      -Change the authentication method; add the destination computer to the WinRM TrustedHosts configuration setting or use

    HTTPS transport.

    Note that computers in the TrustedHosts list might not be authenticated.

       -For more information about WinRM configuration, run the following command: winrm help config.

     

    Error number:  -2147023498 0x80070576

    There is a time and/or date difference between the client and server.

     

    Please note, there is no “destination computer”, all I am trying to do is to run a “quick configuration”.

     

    Friday, February 18, 2011 6:02 PM

All replies

  • Hello

     

    I had the same error message in my environment but When I set Domain Controller time and date to be the same time and date

      as the host I was running WinRM on , the problem was solved.

    So try adjusting the time from the DC side and run "winrm quickconfig" on each server that will be communicating.

    hope that helps

    Tuesday, September 27, 2011 4:53 AM