locked
Visual Studio 2008 - Auto Complete Problem RRS feed

  • Question

  •  

    Hi,

    I recently installed visual studio 2008 on my computer and for some reason the auto complete doesn't work for controls that I create on HTML page.

    I have another computer which has Visual Studio 2008  as well and everything seems to be fine with that one.

    On both computers I'm accessing the same solution which resides on the server. Both have Windows XP as OS.

    Is there any way for me to get the Auto complete to work?

    I reinstalled visual studio and that didn't help either.

    Thank you,

    Niki

    Thursday, July 31, 2008 5:11 PM

Answers

  • Hello Niki,

    I think you're describing "Statement Completion" or "Intellisense." (That is, when you enter the name of a class, the members pop up in a box where you can select them, correct?)  If so, I recommend checking the VS settings for Statement Completion, found in:

    Tools | Options
        Text Editor
            All Languages
                General
                    Statement completion

    Make sure that the "Auto list members" and "Parameter information" text boxes are checked.  If the control assemblies are installed correctly, the members should show up in Intellisense properly. 

    HTH!

    -Kemp Brown [MSFT]
    • Proposed as answer by Kemp Brown [MSFT] Friday, August 8, 2008 11:47 PM
    • Marked as answer by Niki7 Wednesday, August 13, 2008 12:12 AM
    Friday, August 8, 2008 11:47 PM

All replies

  • Hello Niki,

    I think you're describing "Statement Completion" or "Intellisense." (That is, when you enter the name of a class, the members pop up in a box where you can select them, correct?)  If so, I recommend checking the VS settings for Statement Completion, found in:

    Tools | Options
        Text Editor
            All Languages
                General
                    Statement completion

    Make sure that the "Auto list members" and "Parameter information" text boxes are checked.  If the control assemblies are installed correctly, the members should show up in Intellisense properly. 

    HTH!

    -Kemp Brown [MSFT]
    • Proposed as answer by Kemp Brown [MSFT] Friday, August 8, 2008 11:47 PM
    • Marked as answer by Niki7 Wednesday, August 13, 2008 12:12 AM
    Friday, August 8, 2008 11:47 PM
  • Hello Kemp, 
    Thank you so much for your clear answer. That's right I was refering to Intellisense. What you suggested was the first thing I did before posting my message and all the settings were right.
    I finally figured out that I needed to give my computer 'FullTrust' access to the server since the application was on the server.
    Thank you,
    Niki
    Wednesday, August 13, 2008 12:11 AM